Captive portals do not work

Hello,

I have recently tried to connect to several WiFi networks that use a captive portal for login, hotels, airplanes, metro/tube and similar and the portal page is always failing to load.
The error message displayed is usualy a failure to resolve DNS problem or similar. In the networks mentioned above I was able to login via the captive portal with different android phones or iPhones.
I have tried using the IP address of the DNS gateway directly in the browser; in some cases it momentarily loaded the login page/captive portal and then the page loading failed again with the same DNS error. I have tried with different browsers, chrome, firefox and ecosia.
The behaviour occurs also after the latest SW update (FP4.FP3W.A.128.20220516). Has anyone seen something similar?

I don’t exactly understand how you try it out but when connected to a captive portal you should get a notification about this fact and tapping on this notification you should reach the landing page for the authentication page of the captive portal.
Does this all happen for you? At what point do you get the error message?

1 Like

I did not always see the notification to go to the landing page. I cannot guarantee that for 100% of the cases, but that’s definitely what happened in the most recent attempts to connect to such WiFi networks.
When the notification is not shown I am opening a browser to try to access any website (google.com for example). This action on other phones triggers the landing page to be displayed but not on the fairphone. I also remember of seeing a notification that the WiFi doesn’t have an internet connection; I have gone to the settings to select “Use WiFi anyway” in some of those cases but that didn’t help with getting the landing page of the portal displayed.

Not very helpful to you, but it worked fine here just now. I’ll try the one in the train on my way home.

1 Like

Are u using private DNS?

I haven’t changed any of the settings with regards to DNS. How can I check? The only relevant setting I found is under Network and Internet > Advanced > Private DNS where the setting is dns.google. Is that what you are referring to? Should I turn this off? Thanks

You can test it. No problem.
Some captive portal don’t want a private DNS.
Last week I was in holiday for camping. They have a free wlan with a captive portal and i did not work with my private DNS settings. After I disabled it, it worked.

Background:
With a private DNS you can “override” the DNS which you get automatically from your carrier or via DHCP from your WLAN router.
It is usefull, for example, if you want to use a “filtered” DNS, like quad9, adguard, etc. Or if you want to use a “non-filtered” DNS like cloudflares 1.1.1.1, adguards, or dns10 quad9, but not googles DNS, because of tracking.
That’s what I do. I use dns10 quad9 or adgurads non filtering and non tracking DNS because I don’t want to be tracked by google.
I use iodéOS. The use dns10 unfilterd DNS from quad9 as fallback DNS, what means, if you do not get any DNS by carrier or DHCP this DNS will be ussed.

In your case, your fallback DNS should be google in original FPOS. So it should not be the matter, if you disable private DNS or not. Maybe only the fact that a private DNS is configured and the captive portals don’t want it.

In short:
Disable the private DNS, it is not mandotory, and try it again.

1 Like

Thank you for the detailed explanation, I have turned off the private DNS altogether from the settings. I will update back here once I need to use a captive portal again.

2 Likes

Okay so it seems that this has fixed it in my case, tried to connect to IKEA and some other wifis with captive portals and I was getting the notification to “click to login”. Then after clicking on it I get the portal to login and connect as expected. Unfortunately I cannot test again the exact portals that failed (apart from the tube which now works) but for now I can consider that turning off the private DNS fixed it for me. Thanks for everyone’s help.

6 Likes