English

Can't turn off notifications from apps anymore after latest update fp2

Last week my fp2 got the update to Android 9, which caused soms changes in settings. I always turned off the sound and vibration for notifications from any app by simply switching a button next to each app in a settings menu (while still getting notifications on my screen without sound). Now I can’t find that option in the settings anymore. I found a way to turn off notifications alltogether, but I just want the sound/vibration gone. I still want to be able to see if there are new messages without opening the app. How can i do this?

(Other option is ‘do not disturb’ - found a way to get phone calls to come through with dnd on, but for some reason in dnd I can’t turn the sound on at all anymore, eg for listening a podcast. That’s new as well)

Update: thought i found it, pretty well hidden in the settings, but even with ‘vibrating’ switched to ‘off’ for whatsapp specifically it keeps on vibrating…

1 Like

I have the same. I prefer to have the visual notifications so when I watch at my phone I see what I missed. But I don’t want the phone to vibrate or make a sound.

DND is switched off even when I say “until I switch it off” and the Audio Profiles app turns to vibrate when I say sound off.

The Audio Profiles app has a setting “even vibrate when a call comes in”. I wish it had a setting “don’t ever vibrate” or “only vibrate when a call comes in”…

Hope someone knows the right setting or an alternative to Audio Profiles.

I think in the newer Android version the way to achieve what you want is the following: next time you get the notification, swipe down the notification center from the top, then swipe the notification in question to the left or right and you’ll see a cogwheel icon. Tap that and then you can set the notification to silent.

I know that this only works as soon as a notification arrives and you can’t just configure it to you liking immediately after setting up/upgrading the phone.

2 Likes

Thanks for the reaction! Tried it right away, but it has the same effect as what I tried before unfortunatelly (via settings - apps & notifications - notifications - and then you get a list of apps that recently gave notifications and a ‘switch’ next to it): it stops visual notifications as well. Which I do want to receive :slight_smile:

I am following this post as I also find it annoying that you cannot just turn of the sound.
Like you, I like to keep the visual notifications, but I want it to be silent.

Hope there is a solution…
:face_with_monocle:

do you still want sound for calls or all to be quiet? If the latter press any volume key and switch from bell to strike strike through bell and all is quite

1 Like

I want the sound for phone, whatsapp & email (business) but no other sounds.
This is how I had it until the upgrade to Android 9.
In my spare time, I had a look to see if there were any unimportant messages.

Now I have all notifications from other apps turned off completey, but that means I miss the visual notifications too.

Hi, I have a short question since perhaps there is another trick that does it:
running my FP2 with the latest Android 9 version. Running btw very smoothely and faster and more stable than Android 7 :wink:

My question is regarding the notification pop up’s in this android version (other blogs didnt really suggest a working solution): I wish to only block the pop up, which was possible to change in Android 7. The setting moved within Android 9 to another place, if one searches in the setttings for “custom restrictions” it is possible to toggle the setting block pop up. Only thing, that doesnt block all apps from poping up a new message/notification on the screen. Within the notification settings of an app it isnt possible to change that inidividually or overrule custom restrictions. Anyone an idea how to stop pop up notifications from apps?
Of course this is only cosmetic and not a big deal but anyhow, perhaps someone else figured this already out. `Thanks :slight_smile:

A happy Fairphone 2 Android 9 user!

1 Like

Hey bm90001, I moved your post here to have all questions/information about the changed behaviour of Android 9 notification settings in one place.

3 Likes

Good to know I’m not the only one experiencing this problem, though I still haven’t found a solution. I switch between two settings now:

  • ‘Do not disturb’ (with the option to let phone calls come through) when I’m not using my phone, which has the disadvantage that sound doesn’t work at all- not even for youtube/podcasts/social media videos/etc.
  • ‘Vibrate’ whenever I’m listening stuff like podcasts and music. In this case I just try to ignore the vibrating sound from whatsapp-messages coming in - still somewhat distracting, but so far there doesn’t seem to be a way around it when you want to keep getting visual notifications.
1 Like