English

Can't insert SD Card

I have a new SD card. I have copied my whole CD collect onto it. I have just tried to insert it into the slot on my Fairphone 3 but I can’t get it to fit. It slides most on the way in but I can’t get it to click home.

Could I have bought an incompatible card? The one that I have is a Samsung 128 EVO Plus. That’s what’s on the card itself. Other info on the packet days that it has 128GB. microSDXC UHS-I Card. Class 10 4K UltraHD.

Nick

1 Like

In my experience, I have tried several times and after very carefully pushing the card in with my little finger a little further than the end of the frame, it clicked.

1 Like

Hi @Theo7 Do you have an old SD card that you can try?

Nice to know at least you have formatted it outside the phone, and not by the infernal Internal option provided :imp:

Yes, I do. I have a micro SD card in an adapter in my camera.

I’ll have a go…

Nick

The old one won’t fit either :frowning:

N

The end of the card doesn’t reach the frame. I have tried angling it a bit from side to side and up and down.

Perhaps I will give it another go.

N

I have just taken a pic to show how far I can insert the card before it reaches some sort of stop. You will notice that I have removed two of the screws in hopes that it might allow something to line up. It didn’t.

Nick

I am not sure if you are inserting it the right way. When you insert it, it should be directed in a way ressembling the shape of the Micro SD symbol next to it.

Maybe it needs to be inserted with the writing on the backside?

UPDATE: Ah, nevermind. I compared with my own (Samsung) SD card and from your picture it seems that you did it all right.

Hi Nick
a) can you fell the spring when you push it in, your picture shows about how far it will go before you have to push against the spring.

b) I don’t know whether it’s the angle of the picture but all the cards seem a little out of line,

c) You definitely shouldn’t have to remove any screws to see if that helps.

Do you know anyone else with an FP3 that can assess if the spring is just stiff or there is something wrong? and
how long have you had the phone as clearly Fairphone will want to know as soon as possible if it is a manufacturing fault. #fairphoneangel

2 Likes

I have followed the little diagram and made sure that the position of the cutouts match.

So I am certain that I have it the correct way around.

2 Likes

I agree, Amoun. The cards do look a little out of line in the picture. Both Sims are working fine. It’s just the SD that won’t go in.

There is no indication of pushing against the spring. I am coming up against a hard stop.

N

I don’t know anyone else with a FP. I bought it on 13th October 2020.

N

Hi Nick I bought mine on 10th Oct 2020, sadly I’m in Cornwall.

Are you sure that is a standard micro SD card as they have a ledge/flange on the top outside edge so you can pull them out of non spring type slots .
Here’s a picture to show what I mean }~ to the right you can see the extra height. Maybe you could also take the SD card out an show it in it’s totality. I’ve this weird idea that it’s not a standard SD card. Is the shape the same i.e. it narrows at the insertion end, if not it won’t go in and definitely is the wrong sort of card, and I’ve never seen another type.

PXL_20210828_191941669

Actually when I look at the image of yours more intently l think I can see the raised edge. Oh well!

One other thought where did you buy the phone, from the Co-op or a UK based shop as you could take it there/back to be looked at.

Of course if you are going on holiday to Cornwall tomorrow pop by :slight_smile: :beach_umbrella:

No. I bought it on line. Do I will have to get in touch with support.

Not going to Cornwall. I have to confess I am quite pleased not to be going. It will be sooooo crowded!

Thanks for all the help and advice.

Nick

1 Like

Hello.

I am feeling thoroughly negleted by Support!

Ieuan suggested that the SD size was out of spec abd that I should try another, which I did. He asked me for a photo of both of the cards that I had tried, which I supplied a week ago and now nothing!

This morning I measured the cards with my vernier callipers and got these results

Samsung:

Length 15.40mm
Width at narrowest point: 9.72mm
Width at the first “lump” from the narrow end 11.10mm
Width at the wide end 11.11mm
Thickness at the wide end with the fingernail ledge: 1.02
Thickness at the contacts 0.80mm
Thickness over the main body 0.80mm

SanDisk:

Length 15.20mm
Width at narrowest point: 9.80mm
Width at the first “lump” from the narrow end 11.10mm
Width at the wide end 11.10mm
Thickness at the wide end with the fingernail ledge: 0.90
Thickness at the contacts 0.70mm
Thickness over the main body 0.70mm

I have, of course, checked the zero error on my vernier calipers.

The measurements are fractionally shy of the standard spec.

My main moan is the fact that Support oe Ieuan is ignoring me

I suspect that the socket on the phone is faulty and it will have to go back or I will have to repair it mysef if that’s possible.

Do I need to take bite the bullet, ditch the Fairphone and get a normal phone?

Grrr!!

Rant ends.

Nick

My reading are that the micro card should be no bigger than 15 x 11 and the thickness 0.7 (0.6 to 0.8) It appears your cards are slightly on the large side.
http://www.supertalent.com/datasheets/5_112.pdf

But of course the slot maybe damaged? Does the card go part the way in or not at all.?

The spring to hold the card in the slot could be no longer in position. The question is, how did you remove the old card? If you did not push it in first to proper release and remove it afterwards, but pulled it out under force, chances are that the spring is loose and blocks any further insertion. If this is the case, go to a repair shop, they can fix things like this…

1 Like