Can't Create 5 GHz Hotspot after Android 12 Update

The latest beta supposedly allows you to create 5 GHz hotspots once again.

Haven’t tried it myself yet as I’m at work but will try it later.

1 Like

I tried it. The hotspot no longer turns off instantly on 5 GHz. But it starts on 2.4 GHz band even with the 5 GHz setting (but that may be just due to regulatory reasons; the option is called “5 GHz preferred”, so I think it’s okay).

Guys you are revealing beta updates in the public forum while its not avaialble for everyone. Pleae keep this discussion out of the public forum


This has been supposedly fixed in Software update: FP4.SP2J.B.086.20230807, I still face a few issues though:

  • The 5GHz hotspot is really unstable and disconnects connected devices after a few seconds (Turn off hotspost automatically is disabled).
  • It is still impossible to create a 2.4GHz hotspot while being connected to a 5GHz network. You must first disable Wi-Fi (or activate Airplane mode), start a hotspot and then connect to the Wi-Fi again. Otherwise a 5GHz hotspot with the same stability issues is created.

Can anyone confirm this behavior?

Hmmm… while connected to a 5Ghz wifi neither 2.4 nor 5 Ghz Hotspot is stable, its cut after a few seconds, however at the end a Hotspot is meant to be used with mobile data, or?

Without wifi available (tested at home so hat to switch it off), both variants seem to be stable.

Edit: can confirm this behaviour as well…

Why? Sharing a connection to a private Wi-Fi network without revealing your credentials is a perfectly valid use case. Prior to the Android 12 update, this worked just fine.


Ok never thought about this use case, so yes then it should work and I can confirm it doesnt

1 Like

With Android 13 this is still not working, while it works nicely on my company phone from Samsung with A13.

1 Like

Was this reported to Fairphone and did they indicate to be working on it? Maybe opening a new topic would be good, as this is rather a seperate topic? In their public “issue tracker” its (not possible to use 5Ghz hotspot) solved

1 Like

Yes, you are right! That would be a good idea.
I will create a support request… …Done (ID 1087757)

I reported it on August 24th. No answer yet.

1 Like

Also with Android 13?

1 Like

Nope, that’s true, I’ll message them again.

And just FYI: it works on the FP5 with Android 13… It routes the frequency of the Wifi. Maybe it helps them to troubleshoot.

1 Like

The support guys contacted me today after the ticket was not visible to them for days as they claimed. They mentioned

I have checked and I was able to create a hotspot on the Fairphone 4 running Android 13 using the 5GHz band or even dual band and it did not turn off automatically.

and proposed the following:

Can you please check the following support article to see if we can get the hotspot working again?

And - what surprise - it did not help but on top I lost my configured wifi networks. Fortunately I have my device rooted and had those networks backed up :wink:

Tested shortly just now and for me it seems to work, FP4 connected to 5GHz Wlan and FP5 connected with the FP4 shows a 5Ghz connection.

Thats indeed not possible, and should that really work, or does the phone just route the connection/frequency from router to third device?
Btw its the same on the FP5, when connected to 2.4 Ghz wifi the FP5 “hands-over” a 2.4 ghz, same with 5ghz…

For me it still does not work with either 5GHz or Dual Band hot spot. Both immediately get deactivated again. Even after cleaning the connection settings followed by a reboot.

EDIT: In the meantime the support offered to have the phone sent in to the repair center and checked and repaired. But in my opinion the phone is not broken hardware wise, as the problem occured for me only after the A12 update as far as I remember und for me solely is a software topic.

1 Like

Maybe some problem within the settings database? Didn’t they ask for a factory reset before sending the device into the repair center?