Cannot update built-in Firefox Klar

Here’s the setup

Firefox updater reminds me of an update for Firefox klar.

I initiate the update. It gets downloaded. During installation I get this message:

Google Playstore downloads it and then i get a highly helpful error message:


Is this because Klar came with the OS?
How can I update the app or get rid of it?


Another update, this time F-Droid tried it. Failed again, no further information is provided.

Anyone have this issue?

I remember I had a few issues with Firefox Klar when I was on FPOOS, sort of the same as you, so I had stopped using it. Sorry if I can’t help you :sweat_smile:

I have the same error, trying to update FFKlar from 8.0.15 to 8.4.0 with F-droid and it say “incompatible”. :frowning:

Logcat below, apparently an issue with native libraries:

06-17 16:42:50.029   759  9839 I ActivityTaskManager: START u0 {dat=file:///data/user_de/0/ flg=0x2000000 (has extras)} from uid 10039
06-17 16:42:50.074   639   639 W ActivityThread: handleWindowVisibility: no activity for token android.os.BinderProxy@b72af49
06-17 16:42:50.525   759  2999 W system_server: Long monitor contention with owner (788) at void$ waiters=1 in$SessionInfo for 342ms
06-17 16:42:50.552   639   658 W Adreno-EGL: <qeglDrvAPI_eglGetConfigAttrib:607>: EGL_BAD_ATTRIBUTE
06-17 16:42:50.565 30296 30366 W Adreno-EGL: <qeglDrvAPI_eglGetConfigAttrib:607>: EGL_BAD_ATTRIBUTE
06-17 16:42:55.379   759  2458 W NativeHelper: Failure copying native libraries [errorCode=-113]
06-17 16:42:55.380   759  2458 E PackageInstallerSession: Commit of session 1428251640 failed: Failed to extract native libraries, res=-113
06-17 16:42:55.465   759  3552 I ActivityTaskManager: START u0 {dat=file:///data/user_de/0/ flg=0x2000000 (has extras)} from uid 10039
06-17 16:42:55.474   759  3552 E LightsService: Light requested not available on this device. 2
06-17 16:42:55.497   639   639 W ActivityThread: handleWindowVisibility: no activity for token android.os.BinderProxy@22ef3
06-17 16:42:55.712 30573 30573 E AppDetailsActivity: install aborted with errorMessage: L'installation a échoué pour une raison inconnue

EDIT: I’m on LineageOS 17.1

I have the same issue on most up-to-date Fairphone Open OS and F-Droid. Firefox Klar update fails. If I disable it as it is part of the original image, the update still fails. I couldn’t find a way to circumvent this. I believe that adding FKlar as a factory app was a nice step for making the choice of a safe browser easier for users, but it seems it backfired.

I don’t think the issue is related to the app being system-app. Indeed, in my case I have LineageOS 17.1 and FFKlar as a regular app, and I cannot update it either.

Have you tried to update via the same channel you initially downloaded the app? You can’t cross-update an app between F-Droid and the Play Store, since they sign applications with different keys (I don’t know what exactly that means apart from making updates not work either)

I installed via F-Droid, and I try to update from F-Droid.
F-Droid is warning me that the app is incompatible with my device…

Same is here. The text says, incompatible, however, it is brought up as a possible update. When I make it start, it fails. F_Droid requirements show Android 5, so I do not understand what can go wrong. Can it be an F-Droid package issue?

Wouldn’t Fennec F-Droid then be a natural alternative?
I’m using that for a long time now.


Looking on google at the error message "NativeHelper: Failure copying native libraries [errorCode=-113] ", I found some hints that the error could come from the building process, like a wrong targetSDKVersion, a wrong building platform or erroneous renderscriptTargetApi.

So yes I think the issue come from the F-Droid building process…

Yes, the F-Droid build is so far only for arm64 and not for armv7. If some of the extra information is enabled in the F-Droid settings one can see that there is only one 8.4.0 version with “Requires: arm64-v8a”.

Some discussion about failing builds is here in the merge request which contains only arm64 in the changes:

A few days later there is a x86 merge which hasn’t appeared yet in the repo:

But I haven’t found any armv7 merge request.

Yep, I did like you when Firefox Klar stopped wanting to update.

So that would mean (sorry I’m not very very techie) that it fails for all FP2s, no matter the OS?

Correct, this should happen for all OS versions and even most phones from around 2015 and older. For example some old Moto G 2014 which I have here running with LineageOS 16.

armv7 is a 32bit CPU instruction set and the successor is armv8 (also called aarch64, armv8-64 or arm64) which is based on 64bit wide registers. Qualcomm Snapdragon switched to armv8 starting from 2014, but many phones use slightly older chipsets.
armv8 can run armv7 instructions but not the other way around.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.