Cannot phone/message my SIM-imported contacts

hello, fellow Fairphoners!

I just got my hands on a FP3. I imported my SIM contacts using the default Contact app from my app list. The import has been successful, but I have 2 issues:

  • in the Contact app > Customize view I ticked “all contacts”. But none of the imported contacts appear in the contact list. In the app, if I use the search function, I can find them BUT…

  • … I cannot phone nor text any of my SIM-imported contacts. If I go to the Phone app, these SIM-imported contacts are visible in the list, but there also I cannot text or phone them

Any idea of the solution?

Hi and welcome to the forum.

First: Did you insert an SD card and format it as internal storage if you did reformat it as external/portable,

Querying your procedure.

  1. Under Contacts app you have the hamburger option top left > Settings > then Manage contacts you have > Import then the choices are .vcf or SIM, so which did you use? I see no option for ‘app list

Separately on this issue:

Top right of the Contacts app there is an icon showing the contact source, the options there are the one at the top which is the selected one. In my case this is set to Device, there is no option to show those on the SIM card.

hello Amoun, thanks for your messages. I did not use a SD card.
I imported my contacts from my Sim card:
Contact app > Settings > Import > SIM card

I have no Device option at the top right corner of the Contact app. All the options I see there are linked to my main Google account.

Ok The first screenshot shows the icon which in this case shows ‘Contacts from all accounts’ which in my case is only the account on the device as I have no Google account.

The second screen shot show the option if I tap on the icon firstmentioned. The only option I have is Device, but as I said the outcome would be the same. If you do not have the option for device it does appear that the phone/Device hasn’t responded to your attempt to import from the SIM.

I don’t use Google so I wonder if the Google account has somehow interfered, but if it has your contacts then I would expect that account to show.

hello Amoun, again, thanks for your messages and your time. My phone i synch/linked to my Google account. So when I reach the screen that you copied on your second screenshot, I can see listed under “Contacts from all accounts” my Google account name / Add another account / Manage accounts on this device. I actually do not see the “Device” account. And I cannot add it: when I hit the add another account, I’m forwarded to a Google interface to add a Google account.


I’m a bit frustrated that an operation as simple as importing contacts from a SIM card is so complicated!

Yes more than a little annoying, but I think it’s a part of the new google regime, you have to do extra not to conform. :woozy_face:

Can you import again and try and to save to the device?

Glad I don’t use Google :cold_sweat:

Hahaha yes, lesson learned on my side…
I’ll try the new import tonight.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.