Cannot Download anything in mobile network

Hello! :slight_smile:
Like the title says, I can’t download any types of files, from apk’s from the Play Store to jpg’s, png’s and pdf’s from my browser (Lightning). If I try to download something with Lightning, the “downloading-arrow” shows up in the status bar for only half a second and then disappears. The downloading files appear in the list of the Download manager with the comment “Waiting to Download”. If I don’t delete those entries, everything will be downloaded as soon as I connect to a WiFi network. I had this problem with my former phonr too, but only with the Play Store (since, what I found out today, Firefox uses a different downloading system than Android => Which apps and Services can be disabled without causing problems? )
I assume this is because I don’t have " free Internet"in my contract, but I have to pay 4€ for every GB I use and so on and so on. Is there a way to activate mobile downloads?

1 Like

I don’t think this plays a role. Android doesn’t know your data plan.


Try to clear data from Downloads ( and Download Manager (, then reset and try again downloading from at least two different URLs

1 Like

@Roboe Unfortunately it didn’t help. I still get the “In der Warteschlange” (Waiting to doenload) message in the Download manager… But I did clean up 300MB of Data.

EDIT: I have another idea why it may not work. Due to my (indeed strange) data plan I have to have Roaming enabled all the time, since my cellular and data plan are from one provider, but use different networks). Since I have to turn it on, my phone obviously “knows” that I roam. Maybe that’s why it doesn’t work…

Like @TobiasF commented early, I honestly don’t think Android looks after your data plan or your budget. I pay for every single MB and it will download even a 4GB file if I command it to do so. If internet is available, Android downloads any data.

Do you have any firewall app? Any app that blocks or limits internet access, like NetGuard or AFWall+. In that case, you should give permissions to the above mentioned apps (Downloads and Download Manager), because (one of) those are the apps that actually downloads the file.

I didn’t block access with XPrivacy. Like I said, I had this issue on my previous Sony too and back then I didn’t even know what XPrivacy was… :confused:

I ran out of ideas. I assume you mobile ISP respect Net Neutrality, but check if your mobile ISP detects and blocks downloads on your data plan.

P.S.: If that’s the case, read about Net Neutrality and change provider, if possible. I could send you some curated links, maybe

I can’t imagine that this is the case, because I was able to download files with Firefox…

Regarding Net Neutrality, I saw this very interesting episode of a US talkshow a few days ago:

Oh, right, Firefox works, I forgot it does…

I ran out of ideas definitely, :confused:

No problem. I’ll change to a different contract anyway (from the same provider, just cheaper), maybe that helps :slight_smile:

Interestingly, I was just able to download a pdf attached to an Email :confused:

Which OS are you using? Judging from a short google search, it seems like there is (or was?) a bug in Android 7 (Nougat), that prevents you from downloading anything from the play store as long as you’re roaming. If you’re currently using LineageOS, this bug might affect you.

Nope. I am on OpenOs 5.1, but this also happened on my previous Sony with 4.3…

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.