Cannot Charge - Endless Reboots to Charging Indicator Screen


unfortunately my Fairphone (first batch) is sort-of bricked since last night: When I connect the USB charger or attach the USB cable to my computer, the phone displays the charging sign, but the display turns black after a couple of seconds. The phone then displays the charging screen a couple of seconds again later, and again the screen turns black. This cycle happens to continue forever, and the phone is not charged at all; this makes it impossible to turn on the device, as the battery is fully discharged.

Interestingly, I ran into this problem after applying the Unified Storage Upgrade (Cherry 1.6), and the phone got discharged afterwards.

Any suggestions?

1 Like


I don’t think this is probably a bug so have moved this to the help category

Unfortunately I don’t think there is going to be much we can offer by the way of advice if you can’t get any charge into your phone. It’s perfectly possible to “unbrick” but obviously you need some charge to get it connected.

I guess when you connect to your computer you’re not able to see the connection?

I’d suggest contacting support directly as it’s probably going to need to go back for repair/replacement

Hello Chris, I seem to be experiencing sort of the same problem: my FP (1st edition) doesn’t charge anymore. I am using different cables that did do the trick until two days ago, so the cables cannot be the problem. The battery gets charged up to 3% only. I cannot open it , not even with FP connected to the power plug. It seems something is wrong with the battery charging port (is that how you call it, but it doesn’t show any deformities (I didn’t drop it on that spot, or something).
In the FP shop I do not find the ‘port’ among the spare parts…
What to do?


Have you checked your battery? it could be bloated… explained a lot of problems with my phone…

Yeah, you may want to check you battery first, there’s a lot on the forum and Fairphone’s support pages about battery bloating and if that’s the problem you need to get into contact with support directly.

If not, post back.

No, nothing wrong with the battery…

Hi, I am having the same problem. The phone (batch summer 2014) is not charging and endlessly connecting and disconnecting. With the charging sign coming up and then changing to a black screen.

There is not enough power to switch the phone on.

The battery looks fine and is not bloated at all.

Has someone here come up with a solution?

Have you tried with another cable / charger? If this doesn’t work, you might have to repair the USB socket as explained here.

Thanks for the suggestion! I will try another charger later today when I am back home.
Someone suggested a can of air to get rid of any dust in the USB plug. I think I will try this if an alterative charger doesn’t sort it out.

1 Like

I am just experiencing the same problem, beginning this morning.
I tried with 2 different chargers, 2 different USB cables, with no help.

Just ordered a new battery, just in case.