Camera module and display (blue) locks not working

I got my fairphone 2 in december, and noticed that my camera sometimes would not work.
Today I found a screwdriver that fit, and decided to remove the module and put it back, because thats what I have found in the forums.
One of the screws would not come out, even though we could clearly see that it was turning around and around. I eventually gave up getting it out and put back the two other screws.
When I tried to assemble all the parts again and put back on the display, something was different about the left blue lock at the bottom of the device. It would not move to the open position again. Now I cannot properly put the display back, AND my camera isn’t working… I don´t know what to do, does anyone have any advice for me?
Thanks in advance for any answers.

Did you try following the manuals from ?

It seems that you just did what Fairphone’s own official Troubleshooting Tool suggests in cases of camera failure. So in my eyes you did not do anything wrong when you tried to remove the camera module (you never removed and put it back before, right?) – it’s what the TT suggests.

I would contact Fairphone Support and explain the problem. Make sure to mention the screw problem.

Yes, I did remove it once before, to check what kind of screwdriver I would need. The first time I was able to open and close the locks, but not this second time.

Okay, thanks, I will try to contact them.

Well, I was asking because if you screwed in exactly that screw that would not come out now, that might cause problems with Support’s generosity because at least in theory that might have caused the (screw) removal problem now … :confused:

Oh, I have never removed the screw, I cannot seem to. But the display/screen I have removed once by moving the blue switches to open position and sliding the display down.

ok, that’s better then :slight_smile:

I seem to remember someone once reported a similar issue with the blue switches/clips here, and I vaguely believe that one of the horizontal bars that serves as some sort of rail for the movement of the clip was broken.

ah yes, that might well be, but I cannot move the switch enough to see the actual rail. also, the way it stands now seems to lift the flat part connecting to the charging input.

Anyway, I sent a request to the support team just now about it, I tried to explain all the points mentioned above clearly. I will just wait and see what they tell me.

Thank you very much for your time and help :slight_smile:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.