English

Camera issues with Lineage

solved
newcameramodule
lineageos
Tags: #<Tag:0x00007fefbfb79f88> #<Tag:0x00007fefbfb79970> #<Tag:0x00007fefbfb79768>

#8

For me, no problem with opencamera on LOS and the new modules. What are your problems?


#9

@lklaus is right, try Open Camera.
But the stock camera App works with my new camera modules, too.


#10

Thanks for your advice.
I use Lineage 14.1-20170815-UNOFFICIAL-FP2. When I ask for update, it says that there is not available update … maybe I should flash the official version myself and see how it works.

To be more precise :
When I open the LOS stock camera app, it crashes directly.
When I try to take a picture with Wechat, it says that it couldn’t connect with the camera.
I got none of those problems once I put back the old modules. I already cleaned all the contacts carefully.


#11

Yes, that’s an extremely old version. Just download the current one from https://download.lineageos.org/


#12

Here are instructions for migrating from the old unofficial to the current official builds …


#13

I’m not familiar with wechat, i had no problems with my chat apps. Maybe you should we the cache for wecbat? I mean, parameters for the new module are different, resolution and who knows what else b maybe pls parameters are in the way?


#14

It’s not related to wechat itself, my cameras were just not recognized by the phone, no matter which app I used.

Thanks very much. Now I updated to the latest LOS version and the cameras work.

But now … when I try the front camera for selfie, I get two green borders on the edge of the picture. Very strange…


#15

Just to be on the safe side. Did you adjust the resolution of the new modules?


#16

You are right. When I adjusted the resolution, that green border disappeared ! Thanks again :wink:


#17

Hello

When I take pictures in dark environment with the stock app of LOS, the flashlight works before taking the pictures, while focusing, but doesn’t work during the shot itself. So my pictures are completely black …

It works with the Google Camera app.

Any way to fix this with the stock app ?

Thanks


#18

Let’s wait and see … the maintainer was made aware that it is still the same in the first test build of LineageOS 15.1 (based on Android 8.1).


#19

I have a new fp2 with LOS 15.1…910 with microG and the main camera keeps crashing in 90% oft the cases.
It is very Bad, because everything else is working very nicely.
Even the selfie camera works without problems.
The open camera APP keeps also crashing.
Pictures are looking very odd, before the camera APP closes with “mediaserver ist abgestürzt”.
Are there any other options than LOS 14, FPOSOS and waiting?
Before it crashes it looks like this:


Upgrading from *official* 14.1 to 15.1 (feedback/issues)
Camera Error: Can’t connect to the camera
#20

weird… did not have that issue with Open Camera… at least file a bug report at Open Camera…


#21

Have you tried the usual removal & putting back into place of the camera module? Especially the first shot looks like it could be caused by contact issues.


#22

Cant confirm this problem.
Camera (the first module) worked with LOS 14.1 and now with 15.1 without problems. Maybe it is a hardware problem?


#23

OK, sry and I thought it is a known LOS issue. I removed the module completely and put it back according this instruction
Now open camera is working very well after testing it 10 times. The standard camera app claims, that the sdcard is missing, but open camera is using it. Not an issue for me.
Thanks a lot @urs_lesse!
I confirm now the camera is working on LOS 15.1


#24

I’ve FP2 and LineageOS 15.1 20180917, works only front camera not rear camera

suggestions?


#25

Can you try and give the app OpenCamera s shot? You can find in in the F-Droid store.
AFAIK the stock camera app in LOS 15.1 has problems with the flash, which is not in sync while taking pictures.


#26

I’ve tryed OpenCamera too! No rear camera only front


closed #27

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.