Upgrading from *official* 14.1 to 15.1 (feedback/issues)

It’s not. There are a lot of reasons, but here are two concerning impersonation:

  1. Your bank (probably) and other parties use SMS as a second factor of authentication (ie. identity).
  2. In the EU, SIM cards are registered under a national ID, which means they are used to identify people.

Noone can be sure that they won’t lose their phone never, or stolen.

1 Like

Thanks for the answer.

What does that mean? Using a certain app called Miracast? Sorry, i’m not firm with this.
Meanwhile i found out, that VLC can stream videos directly without GApps and it works.


Yes, that’s true, VLC has their own implementation of the protocol which is not dependant on Google APIs. But for me, I don’t use VLC that way (or barely at all); I’d like to use it for Netflix & Emby and as remote. Anyway, it is a clever solution you mentioned.

Miracast is an openly specified protocol as alternative for Google Cast. Microsoft uses it (Google is the new Microsoft…).

hey, is the new camera module working currently? i can’t find the current known issues

Sometimes, when i switch on the phone to see the time or notifications (without unlocking}, the phone won’t switch off, which normally it does after a few seconds. Anyone else sees this?

Main Camera keeps crashing in LOS 15.1…(910with microG)

1 Like

I’ve currently a LOS 15.1 version running that was upgraded from last LOS 14 version, including all apps, data, etc.
Today I wanted to run a clean LOS 15.1 installation.
In TWRP I wiped almost all, dalvick / ART Cache, System, Cache, Data and Internal Storage. Only ‘SD-Karte - Adopted Storage’ remained untouched.
In addition, I’ve renamed /external_sd/media/0/Android, so that this directory is not available anymore for the fresh installed LOS.
But after installing LOS 15.1 and Open Gaps Nano and then rebooting to system, I still had all my apps installed, and the screens still contained all the app icons as before.

Why this happens? I thought when wiping Data and Internal Storage, it is kind of factory reset, at least all apps and configurations previously done should have gone, or?

Did you wipe your internal storage with the wipe -> format data option in TWRP?
If I remember correctly I faced the same thing and this worked.

I didn’t dare to format data, expecting then that also the data on the SD card gets deleted.
How format data works? Does it touch the SD card?

So, some days ago I updated from 14.1 to 15.1 myself.

Now I run into some WiFi issues that haven’t been there before the update. Basically the bandwidth is VERY slow… and my router is like literally 2 meters away from the phone.
The router works fine, my Linux tablet doesn’t encounter any speed issues either and a speedtest via my wired computer showed no problems.

No idea what would cause those issues, maybe faulty configuration with the WIFI internals in the ROM? I might look a bit deeper into this, since it annoys me and I want it fixed.

If you have any ideas or a possible fix, I’d appreciate any answers. :wink:

1 Like

What encryption method does your wifi router use? CCMP (AES) forced should be the way to go.

And does it force protected management frames? The latter made me have problems with my FP2’s wifi - setting them to optional made everything great again. :wink:

1 Like

Thanks for the hint with PMF, which were added in Fritz!OS 7 for my AVM router. As I’m also suffering from massive connection problems I’ll try to disable them again. I thought it would be nice security wise, but FP2 seems to not handle the protected management frames correctly :-/.

Yea, I use CCMP.

I can’t say anything about forcing protected management frames, because I still own a “castrated” ISP branded Fritz!Box Cable 6360 which doesn’t seem to mention anything about such things. Can’t even enable the telnet/ssh server on there. =
I’d switch to 5 GHz in a heartbeat if my Chromecast would support that.

I took a glance at the logcat output too. Couldn’t figure out much, other than a couple of errors which may or may not be related to the issue.

09-22 03:12:11.819   447   447 E wificond: Failed to get wiphy index from reg changed message
09-22 06:56:20.139   316   316 E android.hardware.wifi@1.0-service: Failed to get firmware debug dump: NOT_SUPPORTED
09-22 06:56:20.144   316   316 E android.hardware.wifi@1.0-service: Failed to get driver debug dump: NOT_SUPPORTED
09-22 13:15:58.319   447   447 E wificond: No Offload Service available
09-22 13:15:58.570   316   316 E android.hardware.wifi@1.0-service: Failed to get driver version: NOT_SUPPORTED
09-22 16:34:38.100  1261  1782 E BatteryExternalStatsWorker: no controller energy info supplied for wifi
09-22 16:34:38.100  1261  1782 E BatteryExternalStatsWorker: no controller energy info supplied for bluetooth
09-22 16:34:38.137  1261  1782 E BatteryExternalStatsWorker: modem info is invalid: ModemActivityInfo{ mTimestamp=0 mSleepTimeMs=0 mIdleTimeMs=0 mTxTimeMs[]=[0, 0, 0, 0, 0] mRxTimeMs=0 mEnergyUsed=0}
09-22 16:35:49.648  1261  1768 W BroadcastQueue: Background execution not allowed: receiving Intent { act=android.net.wifi.supplicant.STATE_CHANGE flg=0x24000010 (has extras) } to com.fjsoft.myphoneexplorer.client/.BroadcastListener

The “no controller energy info supplied”, “Background execution not allowed” and “modem info is invalid” error/warnings are like a LOT in the logcat I dumped (-db system; only Warnings, Debug and Errors).

1 Like

Depending on your router model you can maybe make the PMF optional, removing them completely still weakens the security of devices which can handle them correctly (my years old computer indeed does).

Well I disabled them, but my Wifi is nearly unusable. Because I’m using Orbot, which isn’t able to handle all these re-connects to my WLAN, I just disable WLAN on my FP2 at home. Sucks! I didn’t yet try to debug this. I’m also not sure if this was introduced by a recent LoS 15.1 update or by the Fritz!OS7…

My observation after updating from LOS14.1 to LOS15.1:

  • Update via TWRP, just by flashing LOS-ZIP
  • needed to flash also addonsu-15.1-arm-signed.zip (was not neccassary within LOS14.1-updates)
  • I installed no Google-Services (no MicroG or similar)
  • all data stayed untouched (I did no wiped any cach or partition during installation), except:
  • homescreen was empty (all symbols have to be re-added, also all widgets)
  • Google Maps is not working anymore (updated to v. 9.86.1 via Yalp), it starts but after loading the map properly it crashes & closes. In LOS14.1 it worked this way! Why? is now working - after I updated to v. 10.1.0 (in Yalp Store)!
    So it was not a problem of missing services, obviously.
  • Bug of LOS14.1 still there: PIN of SIM2 has to be entered twice (2nd dialogue sometimes just vanishes)

I quit using LOS 15.1 and reverted back to 14.01. I wiped and reinstalled EVERYTHING, Installed LOS14.1 and all my apps worked (Google Maps, Mamikreisel, Kleiderkreisel). Then updated to LOS 15.1. Then the first opening of Google Maps worked, found GPS… When I opened it the second time, it just dumped. Same with the other apps.
I will hope for FP Sibon to release th version with SuperUser and switch to that. Then I will get upates again.
I’m sorry it didn’t work - but I need my phone!!!

No idea why it didn’t work properly. I’m using maps well, just guided me from UK to Belgium and onwards back to France :disappointed_relieved:

1 Like

I regularly use a Wi-Fi (WPA2-PSK AES-CCMP-128) which has enabled optional PMFs. The FP2 actually uses PMFs and the network performance is good. (I’m on FPOS 18.09.1 (GMS), not Lineage.)

Does your FP2 use PMFs when you set them to optional on the AP?

Sorry to hear that. What setup are you using? Which zips (esp. which gapp packages) did you install on top of lineage? Did you install gapps directly when upgrading? Meaning no intermediate reboot after lineage? You know that you have to flash a new gapps package when upgrading?

Can you also provide logcat when it crashes?