Camera Flash is not working

Hi there,
I finally got my phone on monday and now after testing most things i found out that my camera flash is not working.
I tried in Camera mode and with the Torch App from F-Droid aswell as the flash light option in the notification bar.
There seems to be no damage to the camera module so i guess it’s either software or the flash module i broken.

I did not root the phone or change the OS i only installed apps from F-Droid and deactivated some google apps.

Does somebody else have a similar problem or knows a fix?

At my FP2 the flash works fine, with camera as well as used as a torch.

So my guess would be that you unfortunately may have a hardware problem with your flash.

Maybe disassembling and reassembling could fix this? Otherwise I’d contact support.

Thanks for the quick responses.
I already feared it would be a hardware problem.
Guess i will disassemble and reassemble now and see if that works…


I encountered only now that the flash of my FP2 does not work with other cameras, only with the shipped/stock camera as well as used as torch light; but not for other camera apps.

Tested now with OpenCamera and Focal where it does not work.

Edit: Sorry, false alarm. Don’t know why it didn’t work with OpenCamera earlier, now it seems to work (again). Though with Focal still not working; maybe an app issue …

1 Like

Thanks for mentioning the app OpenCamera. After installing I discovered that my FP2 camera flash works! Before, with the Google camera, the flash was not working. I am also amazed about the great functions of OpenCamera (i.e. locking/unlocking the lighting measurements right from the live view) and how smooth it is.