CalyxOS (is coming to) is here for FP4!

Is THIS also relevant for CalyxOS?

The FP4 comes with an anti-rollback feature. Google Android anti-roll back feature is supposedly a way to ensure you are running the latest software version, including the latest security patches.

If you try installing a version of /e/OS based on a previous AOSP core version than the one running on your phone, or based on a security patch that is older than the one on your device, you will brick your device.

To check the security patch level on your phone with a locked bootloader, prior to installing /e/OS, open your phone Settings » About Phone » Android Version » Android Security Patch Level.Then compare it against the level of the security patch on the /e/OS build as visible in the Downloads for the FP4 section below.

AFAIK my FP4 is currently on Android-Patchlevel from 05. July 2022 and the only offered CalyxOS files I found ( seem to be from May 2022 (May 2022 Security update - Fairphone 4, OnePlus 8T, 9, 9 Pro).

Help wanted, before I get a working USB-C data cable and brick my FP4 :-D.

I’ve asked the devs already if that is relevant to CalyxOS as well, so far there hasn’t been any movement on that issue (DEF CON ended just a few days ago, people need a brake sometimes :slightly_smiling_face:).
My guess would be, yes, definitely.

The 3.7.2 beta I linked is at patch-level 05. July 2022 as well, so you would be safe on that front, but I would still consider leaving the bootloader unlocked.
I can’t repeat this enough, whatever you do, check fastboot flashing get_unlock_ability!


I read in the other CalyxOS thread, that Magisk (which I need) requires unlocked bootloader, so yes I will leave it open once I can get onto the installation :). Thanks!

1 Like

I was at that point as well and basically followed @R2D2 's steps here. As I also wanted to add Magisk, so I created my own notes, which are mostly similar and only a bit different at the Magisk part. So I did not post it again and just confirmed that it worked. (maybe helpful for others when we add another wiki post like “Howto install Calyx OS with Magisk on FP4” or so)

Or you just combine the infos of:

like I did. :wink:

(and I didn’t though about the patch-level thing, but I directly flashed Calyx after my FP4 was delivered)

1 Like

That “The bootloader is unlocked” message during the start of the phone is really annpyong :-1: .

1 Like

So I flashed CalyxOS, had to upgrade the fastboot executable on my box in order to get the working ;). During the first boot the OS warned me that I should relock my bootloader, which I did not.

First impressions in comparison to LOS, it’s looking ugly and I have to get comfortable with that default design and launcher. I’m already missing the extended reboot-menu and the screenshot option in the Power-button-press-menu. The preinstalled apps selection is great! I’m still in the process setting options as I had them on my beloved FP2 with LOS 18.1.

Can I move my FP2 seedvault backup to the CalyxOS FP4? I even don’t want to lose my own dictionary, which has gotten SO many words over the last years ^^.

Currently there is no newer version available even when switching to beta.

I’ll keep you updated… Thanks for all your help.

That’s Android 12 for you :smile: takes some time to get used to coming from a Android 11 ROM.
I actually kind of like it, set the background to that gray Calyx :zap: and it will get a lot less colorful.
Haven’t found an option to enable the extended boot menu though.

I mean, Seedvault started in CalyxOS originally, should be pretty standard, so it’s definitely worth a try :crossed_fingers:

There is an issue in Etar regarding notifications:

CalyxOS has fixed this in it’s default calendar (which is based on Etar) already:


I know that option from LOS (which was the OS I used on my FP2 as well), but I never used the screenshot option in the power menu. Why not taking a screenshot pressing Volume Down + Power ?

Or if you configured the 3 button navigation on the bottom of the screen → open the running tasks with the square button on the right (or however the open task can be accessed):

1 Like

I found gapps for Android 12L here (found it via articles about flashing LOS) and the swipe lib seems to have a new place in Android 12 (L? - I assume it is the same for 12). → /system/product/lib
Also it seem to be the same file since 2008 ^^ (I compared it to the one I still have from Android 11 and used with my FP2).

So as soon as I will get used to creating Magisk modules I will create my own one about this as well.

EDIT: Before doing this I though, that it might be an option to report this to the existing Module devs: GitHub - NullCode1337/GlideLib: Install the libraries required for Glide Typing, systemlessly but the issue section seems to be disabled there, so I don’t know how. :thinking:

I used the arm64 version of the module as the FP4 has an arm64 architecture. On the other hand the lib in the gapps package is located under a normal lib folder ( /system/lib/ or /system/product/lib/ is probably not that important → not lib64 like the module puts it)

## on my FP4 (after enabling the GlideLib module):
adb shell su -c ls -l /system/lib64 | grep libjni
-rw-r--r-- 1 root root  1112352 2022-08-10 23:05
-rw-r--r-- 1 root root    24024 2009-01-01 01:00

Great, that is sufficient for me :).

Is there a way to change the Android 12 accent color within CalyxOS? I’m missing the setting “Colour palette” in Background & Style setting :-(.

Sadly that feature isn’t in AOSP and I haven’t heard of an open reimplementation ready to replace it (but haven’t looked in a while).

There is a live wallpaper based workaround called LWP+, but that isn’t open source and apparently also contains ads, so I haven’t tried it.

Edit: Well, there is the Android 12 Extensions Magisk module, but it seems abandoned and apparently doesn’t fully work on 12L. Calyx devs already said they won’t include it in its current form, which isn’t surprising since they try to stay as close to upstream as possible.
I guess we’ll have to wait for this to get implemented in AOSP or Lineage. GrapheneOS apparently have a similar feature, but nobody is going to touch that code, especially not to pull it into CalyxOS.


So there is a little way to got until feature parity woth LineageOS or is that one also missing in LOS currently? Anyway, I’m still setting up CalyxOS as my daily driver and hope the first OTA-update wont kill me ^^. How are your experiences with OTA updates? Magisk has to be reinstalled I guess? Did you manage to achieve Safetynet checks passing?

That feature isn’t in LineageOS 19.1 either, here’s a recent reddit post asking for it.

OTA updates aren’t an issue, I’ve done all of them without any problems:

Haven’t tried anything SafetyNet related, I use nothing that would need it :man_shrugging:

I’m not sure if Calyx is the right CustomRom for you if you have a lot of customization/colors/etc. needs. ^^

I think all the custom roms have their goal/idea. Calyx is clearly described as Privacy, Security, prevent tracking, Free Software, etc. focusing
(–> About CalyxOS / CalyxOS - Wikipedia)

These goals totally fits at least to my needs (and that it works stable as the FP4 is my daily driver → I can say after some weeks using it this is the case … even CalyxOS is still not yet official)

Even though I have to admit that I also tend to bring back things working the same way as on my old phone (the FP2 same as for you afaik). :wink: The biggest loss for me up to now is the missing notification LED, but this is a Hardware problem and I cannot blame Calyx for that.

I also adjusted the font size as a first step as it felt to big for me (Settings → Display → Appearance → Font-Size → one level down from Default to Small). Apart from that I have chosen my preferred launcher some time ago ( and I think if you have one as well it will always bring back more or less the same look and feel.


Leider in einem Englisch was sich nicht in Deutsch übersetzen lässt

The same holds true for me, I found it to be unusal big but choose a lower element display size.

I confirmed that it’s possible to use an exFAT formatted SDCard, which was not possible for FP2. F2FS also doesn’t yet work. I’m using Signal backups to external SD and for files bigger than 4GiB FAT32 doesn’t work anymore.

Is anyone using OpenCamera and has some configurations hints for me :)?

Interesting. How did you do it, which SD type/vendor do you use and how did you format it (which OS, which tool?) My Sandisk SD is still not working as I would expect it some apps don’t see it of errors occur when they write to it. I also would like to reformat. (same reason btw. - big Signal backups but due to the fact that the FP4 has much more space not that urgent anymore as for the FP2. I also comment on this git issue for supporting chunked backups for Signal → introduce chunked backups by Roghetti · Pull Request #11900 · signalapp/Signal-Android · GitHub )

Open Camera: Maybe start reading this Thread :wink: : Camera & Camera2 API - missing features & bugs

I wouldn’t format the card inside the FP4, the process killed the partition table of my bigger Transcend card everytime I tried it and my smaller one always ended up as FAT32.
You can write files >4GB to a FAT32 microSD, but the consequences can be catastrophic (:de:)

Just format it on your PC, GPT partition table and exFAT should work just fine. But a SanDisk card might still find a way to fail :smirk:

Those might be the main goals of Calyx, but the fact that it’s AOSP based might make it appealing to other users as well.
Personally I want / need those privacy features, but I’m mostly using it because it feels more vanilla, and somehow different in small ways, after over a decade of LineageOS (and CyanogenMod) :slightly_smiling_face: