CalyxOS (is coming to) is here for FP4!

I used my Ubuntu 22.04 box and formated the SDCard via a MicroSDXC-adapter from Kingston as exFAT and inserted the 64 GiB card into my FP4 afterwards. It’s working nicely, and I use it mainly for backup purposes.

Edit: The card is a Samsung EVO Select 64GB microSDXC UHS-I U1 130MB/s.

Thanks for the camera link, will have a look :).

So formated just via default “Disks” application? (assuming that you have a Gnome Desktop)

Yes, that is correct.

The system does it on both laptops and both are up to date as you know. So it doesn’t work on two systems, so it can’t be because of me. It might not be on linux or any flash bar
root@t510:/home/carrabelloy/Downloads/FP4-calyxos/FP4-sp2a.220505.002# sudo ./
fastboot too old; please download the latest version at SDK Platform Tools release notes  |  Android Developers

As the message indicates, you need to update fastboot, the install script has checks to detect if the installed version is to old.

What distro / version are you running? :thinking:

That’s what I did when I used the old package, i.e. the developer package from Andriod. Or how should I update Fastboot

Depends on your distribution, if your package manager has a version new enough (CalyxOS needs at least 31.0.3), install that.
Otherwise download the SDK Platform Tools, extract them and either move them to a directory in your $PATH or just run fastboot directly from that folder ./fastboot (but you would have to modify the install script then).

What’s the output of fastboot --version on your PC currently?

1 Like

fastboot version 28.0.2-debian
Installed as /usr/lib/android-sdk/platform-tools/fastboot

Hi there, I suspect it’s a bug in the script.

Please delete or comment the following lines in the script in try again:

if ! grep -q partition-exists $(which fastboot); then
echo “fastboot too old; please download the latest version at SDK Platform Tools release notes  |  Android Developers
exit 1

I’ve moved your reply to the Calyx thread, otherwise we’ll end up in some complicated language chaos :smirk:

Are you sure there isn’t a reason the script needs at least version 31.0.3? :thinking:
Why include it otherwise…

1 Like

From my ancient rusty German skills I thought I understood the user was sure to be using the latest version.
I actually ran into a similar issue on the windows version of flash-all.bat whereas my fastboot was the latest ones. This solved it…


I would like to repeat that again, why do you really have to update to the latest version of Fastboot now? Why does everyone have to cook their own soup? Why not take an older version that runs on all systems. This is crap. I’m fed up. Typical Americans who always do this with software. I am looking for another software for my FP4. Because I’m not doing this circus anymore. It’s getting annoying. Thank you for your help.

Probably because there are changes the script relies on, I would suspect it to be the ones introduced with the requested version:

31.0.3 (August 2021)

  • fastboot
    • Support flashing vbmeta_vendor.img for fastboot flashall / update.

You could try to get it running with an older version and create a pull request to CalyxOS (or inform them that it already works flawlessly with version xx.xx).

The newer cersion of fastboot will run on your Debian 11, it’s just the package which isn’t up to date. You can download it and run it directly by using the complete path.


Habe ich versucht, doch leider hat das nicht geklappt sudo export PATH=/home/carrabelloy/platform-tools/lib64/:“$PATH”
sudo: export: Befehl nicht gefunden

If you look at the release notes you will see a lot of fixes and improvements during the 3 and a half years since your version came out; don’t you think among all these changes might be one or another that makes sense to use and rely on for todays developers?

1 Like

That may be the case, but I don’t think it always seems to be good without a surface, i.e. distros.
You see the problem again and again where the errors also appear and the whole thing often comes to a standstill. That’s why I wouldn’t use Arch or Fedora. Always Debian

try export without sudo and then fastboot with sudo

?? what do you mean please?

I also tried export without sudo, but the system probably doesn’t eat it.