Call function doesn't work. Doesn' it know that it is a PHONE?

My phone disconnects all my calls after about 30 seconds and switches to flight mode. To use it again I have to enter my pin. What’s wrong with it?

Hi @brs

First of all, I’m not trying to be rude but I don’t think the second part of the title of your topic has any benefit to trying to find a solution. Furthermore, this forum is community based so people with similar problems can find a solution as well: please try and use relevant, easy-to-find titles.

Have you tried soft (or even hard) rebooting/resetting your phone? Has this been happening from the beginning or after a certain update? Or maybe after installing a specific app?

Some details on what the problem exactly is, or the steps you need to take to make this issue happen, would be quite helpful to aid us in finding a solution for u. Simply asking “what’s wrong” doesn’t work. This doesn’t work either when you’re sick: the doctor needs to examine the symptoms and find an adequate diagnose. Imagine “the forum” as “your doctors”. :slight_smile:

Kind regards,


1 Like

Seems to have similar problem.
No ringing. Then I can’t hear anything, nor can the person I’m calling hear me.
Music works.

What could it be?



Dear Robin,
thank you for your reply. I’m sorry, if my request is not well articulated, it’s the first time I write something of this kind and I’m not an English native speaker. I’d try to specify the problem if I could, but it appeared with no recognizable reason. I did not install a new app for many weeks and did not change any setting. I have not tried a hard reset yet. I hoped, an update could help, but it didn’t.

It’s a little bit different, because mine is ringing and works for a couple of seconds. But then the call is interrupted. Maybe some member of the community can help us.
Best regards

Try a hard reset to see if this solves your problem: read this very carefully.

If with this reboot the issue isn’t resolved, I’d recommend you contact the support team.

@brs, @Matthieu_Bonaventure, before doing a “hard reset” as suggested by Robin, have you seen this topic about rebooting phones - maybe it could be the same problem perhaps?

It’s a specific problem that is occurring when a phone has the Gmail lockscreen widget activated and phones seem to reboot shortly after unlocking. As you’re experiencing a similar problem when taking call which technically unlocks the phone, I wondered if this may apply to you?

The solution is to remove the Gmail lockscreen widget for the time being - it’s been reported to support as a bug to investigate.

Have a look and see if this helps

1 Like

I did reinstall the whole phone from the verry begining and … it does allow me to call. Un vrais succès! Merci.

1 Like

Ow, didn’t know about that one. Thanks for the info Chris !

1 Like

Dear @Chris_R

thanks a lot, I will try to find out if this is the reason for my problem.



Hi @brs and welcome to the forum,

this might sound obvious but i had a similar problem because i “was holding my phone wrong” eg. the touchscreen was active during the call because the sensor did not work correctly. If you accidentally enter the “quick settings” with your ear, the “airplane mode” button is right at middle at the top of the screen so easy to activate. When entering flight mode, obviously all calls are dropped.
It took several calls for me to notice, so it might be similar in your case?


My phone hangs up 10-15 seconds into a phone call. I’ll try a hard reset tomorrow, hopefully that will fix the problem. Is this a common problem with the Fairphones? After all, it doesn’t help me much that it is fair(er) if I cannot call people with it …

1 Like

For the record: I’ve been in touch with support and will send my phone off to them to have it fixed (I hope).

1 Like

I’ve discovered the same problem! Have you found the ‘right’ way to hold your phone or lock it during calls? Every time I finish a call I find that I’ve activated all sorts of interesting things with my cheek/ear…