Reboot issue even after update (GMail Widget Issue)


My Fairphone (FP1, OS 1.3) occationally reboots - blue screen with FP-logo and “start a movement”-splash, followed by lockscreen and the phone searching for networks. This happens 3-5 seconds after unlocking the phone, seemingly independent of other apps and widgets, during which time the phone is inresponsive. It happens aprox. 20-80% of the times I unlock, more often with less battery power. I’ve had this problem since before the update and it still persists. I’ve checked around but my problem seems to differ from other reboot/crash issues. Since it reboots in connection with unlocking the phone, I’m never “interrupted” by it while using the phone - once it has rebooted it works fine until its locked again. The biggest problem is when taking calls while the phone is unlocked (which acts like unlocking the phone). With the same frequency the phone will reboot mid-call, a couple of seconds in, which is frustrating since it can’t be foreseen or avoided.

Is there anything I can do to fix this?

Best regards,


Damn, it’s a bummer.

Have you tried installing the latest 1.5 version ? Maybe it corrects that…

1.5 is not available for first edition phones.

@emastr do you have the mood background set on the lockscreen? You can check this in settings > display. This has been known to cause some crashes with some third party apps installed. If it is currently enabled try disabling it and see how you get on

If not, might help to know what unusual apps you might have installed add this could be causing some instability.

Failing that, as an absolute last resort there is a hard reset but wouldn’t recommend that yet anyway

Thanks for the tips. I do not currently have mood background enabled and I don’t have many apps at all installed. The ones I have are ethier the ones that came with the OS, Google apps (like Books, Translate) or more reliable third party apps (e.g. Adobe Reader, Soundcloud, WhatsApp). The reason why I don’t think it’s caused by an app is that I’ve had this problem for quite some time and it doesn’t seem to be related to what’s installed.

Though, come to think of it, I think the problem started when I installed and played a game with a little bit heavier graphics requirements, nothing extravagant, but still more than the usual phone games. I uninstalled short thereafter (this was months ago) and have installed the 1.3 update since. I don’t know if that game had anything to do with it, but that’s the first time I can recall I had the problem.

Wow?! Seriously? FP are so stuck like that? :S

Hi @emastr

Mmmhh I think it’s unlikely that the game itself would have caused the issues unless it contained some kind of malware or some kind of incompatibility that’s corrupted something.

If it is any kind of file/config issue, then a hard reset would likely clear it… but if it’s not that kind of problem then it’s a whole lot of messing around. Maybe worth a try though as something is causing it to crash. Details of how to do a hard reset here if you want to try: but you’ll want to make sure you back anything up that isn’t stored on the web somewhere already.


FP OS v1.6 is out today. There is also a separate fix available for the storage issue which involves erasing all data on the phone - so it may be worth installing the updates and starting again from scratch rather than doing the hard reset I suggested before.

Same problem here!

I don’t have the mood enabled also and I haven’t installed anything “strange”.
The update to version 1.6 doesn’t solve the problem.

May someone from FP have a closer look on this issue?

Many Thanks!

@emastr did you do the v1.6 update and storage update, and how is this problem for you at the moment

@Christopher can you give more detail as to what is happening and when?

Out of interest, are you using the official FP case, and if so have you tried giving the case a little bit of extra bending just in case this is depressing the power button?

@Chris_R it randomly happens shortly after I swipe to unlock my FP. Unfortunately I can’t reproduce or force the FP to reboot. It always occures when I want to start an app after unlocking the phone no matter which app I start.
Sometimes it happens 4-7 times a day or maybe only once. Pretty disapointing.

And no, I ain’t using any case at all. :slight_smile:

1 Like

You might need to log this with support as an individual problem as it doesn’t seem to be problem that everyone is having.

Are you using any unlock security like Pin or pattern etc? And if so have you tried deactivating or trying a different method of unlock? It might just be co-incidence that it happens when you unlock, but worth investigating.

Yesterday I deactivated every lock mechanism. i hope it works but that can’t be the solution because
I don’t want to have my FP unsecured all the time.

I agree it’s not the solution, it just helps narrow down the problem :slight_smile:

Ok, seems like I do have a solution now.
I found the clue on another FP forum page (check the first reply from Stéphane Guillou):

I have no idea who put the google mail widget to my lock screen because I didn’t.
Not sure if this has happened automatically during an update?

Anyway, I had no “crash” since I deleted the gmail widget from my lock screen.

Keep fingers crossed!

1 Like

Yep, that seems to do it for me as well. No crashes since i removed the gmail widget.

Thanks a million!


[Edit by Moderator: Removed the email from this topic]


Excellent news @emastr & @Christopher

I will report this as a bug to support.

[Edit: I’ve updated the title of this topic to be more specific to reflect the issue]

1 Like