Bypass screen pattern

My FP3 does not recognise my screen unlock pattern any more - or I’m driving crazy… I’ve been using this pattern since I bought the FP three years ago every day, bt suddenly it says “wrong pattern”. :-o
However… I obviously would like to avoid a hard reset and I’ve browsed the forum already for similar posts and found a hint by @Ingo from Jan '19 which says “It’s actually pretty easy for non-encrypted phones: Remove /Bypass Lockscreen With Recovery | XDA Forums 156”. The problem is that I don’t understand a word of how to boot my device with TWRP for Fairphone 3. Would Ingo (or anyone else) have the amiability of translating the how-to for a non-professionial?
And: do I understand well that if my FP3 is encrypted than there is in any case no chance to save my data?
Thanks a lot for your wise advice!
Rainer

Hi and welcome.

Did you get as far as downloading to your computer and reading this?

Welcome to the community forum.

You would only need to concern yourself with that if you run your phone with an unlocked bootloader (if this sounds unfamiliar, you probably don’t), else you can’t boot anything other than what is installed on the phone.

Locking as well as unlocking the bootloader will force a factory reset for security reasons.

User data on the Fairphone 3 is encrypted by default. Since a pattern for the lock screen is set, this pattern serves as the unlock method needed for decryption.

If this would be bypassable now without any other user credentials, anybody getting hold of the phone could bypass it the same way, too.
Google dropped a respective “Forgot Pattern” feature after Android 4.4, and Google Find My Device can only erase the data as far as I’m seeing.
Google currently says: “If you can’t unlock your phone, you’ll need to erase it.”

While I sympathise with the situation, I quite frankly don’t want this to have a solution visible on the internet :wink: .
(At least if it’s not something like the “Forgot Pattern” feature of yesteryear, where the Google account on the phone and the password for it were needed.)

2 Likes

Hi amoun,
yes I did.

1 Like

Hi AnotherElk,
thanks for your reply!
No I hadn’t unlocked the bootloader beforehand. I had done this on my previous phone (Ericson) in order to upgrade the Andriod version, but as FP provides Android upgrades, I haven’t thought I’d need that one day.
Google does not seem to be able to connect to my phone, seemingly because localisation is off and needs the unlock pattern to be turned on!
I also believe I had stored all personal infos, photos and so on on the SD card, but plugging it into my PC I can’t see anything of it. May it be that the content of the card is equally encrypted? Will it be read again after a hard reset?

Upon first use, Android would have prompted you for how to use the card.
If you chose to use it as Internal Storage (as opposed to external/portable storage), the same encryption applies to it.

The usual reminder in this case: Please see the #sdcardguide . Use of SD cards as Internal Storage is strongly discouraged (for other reasons, though, it’s just not stable).

I’m just wondering how this would happen.

Could it be the touch recognition is off by a certain margin? Do you see that the correct dots are being used when you input the pattern?

Do you have family/peers who could know your pattern and are now trolling you (having it changed unnoticed by you)?

2 Likes

Might it happen that a corrupt SD card configured as internal storage breaks the ability to login with the known pattern? :thinking:

@Rainer_Arndt : are you sure that your data was not also backed up to Google cloud? I think this may be the standard setting on a non degoogled phone…? That would help to restore your data.
You might try to login into your Google account on the internet to check…

1 Like

Hi Volker
only my contacts were backed up to Google, not the content of my SD card. So I hope everything will reappear after the reset…

Since it wasn’t mentioned … did you try to turn off the phone, wait a few seconds and turn it on again to see if it’s perhaps just some hiccup?

Yes I did… That was actually the first thing I tried. I couldn’t believe the phone would just continue to tell me “wrong pattern”…
It’s actually scary. I wonder if it could be some kind of virus.

I had seen this possible reason on the forum, but it really looks like all the dots are correctly connected when I draw the pattern.
My kids don’t touch my phone…

I wish you’re right with that! But technically I quite doubt it. If the SD card was formatted as internal storage then it’s encrypted and the key for decryption will “disappear” with the factory reset.
Sad truth is possibly that only regular backups protect you against this in the future…

Btw.: did you #contactsupport . There might be faint hope that they know a solution which keeps your data…

4 Likes

One possibility would be that the key data storage on the phone got corrupted. The original pattern can possibly not be validated any more under those conditions. In this case there will be no way to still unlock your phone and get to your data as the key itself is already destroyed.
But this is only a guess based on how other encryption solutions (LUKS, VeraCrypt, …) work, I have no idea if Android actually does it like that.

1 Like

So, I’ve hard-reset the phone. Everything lost except of my contacts which were saved to the Google account. This was quite a painful lesson… I learned what to and which options to chose with the SD card, bootloader, USB debugging, backups …
Thanks for all your care and time!
Cheers

5 Likes

Hi guys, just for the story: after having made a factory reset, this morning my phone greets me with this message: “Zur Verbesserung der Sicherheit ist eine PIN erforderlich” (it’s in German…). This time a had choosen a number, and I had noted it down in a safe place. Guess what the phone says when I enter the PIN?
EDIT: apparently not so uncommon an issue, if you google “android not accepting correct pin”… pffff

Ok, there is something wrong, this message is not normal. I always use PIN to unlock and have never seen that message. Are you sure its really from lock screen and not from any installed security/clearing/antivirus App? Can you start in safe mode #dic:safemode

Correction: have you seen the message when you startend/restarted? Then it might be its correct, with Iode OS I see “after restart the PIN is reuqired”, maybe with other OS its just phrased a bit different.

Edit: have you done the boot/reboot or did the FP reboot out of the blue? Do you again use the SD card and how did you Format this time?

It’s the same scenario in safe mode. I tried all this also the last time.
When this happened last week for the first time, I could believe it was a technical glitch, but the same thing happening again after 4 days?
My guess is a virus or misfunctioning on the SD card. I did not externally reformat the SC card (eg. through the card reader in my PC), because I believed the phone would re-format it on first use. I’ll try that with the next factory reset. At least this time I haven’t lost anything but 2h of time reinstalling the whole thing.
Edit: when this happened this morning, the phone was ON, just like last week. Suddenly when I picked it up with fingerprint it asked for the code and didn’t accept it anymore. What was new this time is the message “in order to improve security” - I have never seen this before.

UPDATE:
I don’t believe it: I entered my SIM card pin and it unlocked!!!
Please note: I had de-activated SIM pin identification. And last week it asked me for the pattern, so I didn’t even have the chance to enter a numerical PIN. Please, what a sh*t is that???
Edit: Just saw on the web it could be an issue with the Nova Launcher. But shouldn’t it have worked then in safe mode?

I think it is quite obvious: if you had de-activated the SIM pin identification previously, that setting got lost with all the other data when you did the reset. Which means everything is back to defaults and whatever setting you had changed now needs to be changed again.
I would call that expected behaviour.

2 Likes

On this, when inserting an SD card you will have the option of formatting as Internal or Portable. If the SD card has been formatted on a PC for example, and|or has data formatting as Poratble does nothing. Formatting as portable only effects a non formatted SD card, and then it does add some ‘rubbish’