Bug: Android 10 FP3 - Unknown Caller

I don’t have te option to disable “4g lte…”
Theee are 2 sims in my phone; Kpn and Truphone.
In my settings I can disable the advaced setting for Truphone sim but the kpn hasn’t got that option
I do have the troubles with unknown incoming calls

It’s normal, you can have only one SIM in 3G/4G, the other one is blocked on 2G (I think, that was the case with FP2 and I think it’s the case with FP3 as well).

No that’s not the case anymore with the FP3.

3 Likes

Here same problem since update to android 10. No Caller ID. Network KPN. Netherlands

I’m new with Fairphone and I had the same problem. I changed it and now it works with the transfer of the saved names.

I’ve had an update from FP this morning asking for more information to try and figure out what’s happening.

Anyone still having the issue, I suggest sending this info through to FP

I am contacting you again, because we would like to ask you, if possible, for further details.
Since we are still investigating this issue, I ask for your collaboration to help our developers to investigate it further.
We need you to capture a report directly from your device and send it to us. We will use this information abiding by our privacy policy.

Please, follow these steps:

  1. Enable the Developer Options.
  • Go to Settings > About phone > Build number.
  • Tap Build number seven times (enter your phone pin if required).
    Once activated you will see the message “You are now a developer!”.
  1. Go to Settings > System > Advanced > Developer options.
    If the status is “Off”, tap on the first toggle on the left to change it to “On” (the color will change to green).

  2. Scroll down the options and enable Turn USB Debugging and Bug Report Shortcut.

    • IMPORTANT - Restart your phone.
  3. Reproduce the issue making sure to perform all the usual necessary steps. Before you do this, make sure to enable again VoLTE and VoWIFI. Then ask someone to call you. If you receive still a call as “unknown”, proceed with the next step.

  4. Once done, long-press the Power button: several options will appear.

  5. Click on the button called Take Bug Report…, after a moment you get a notification that the bug report is ready.

  6. Tap on the notification and share the bug report to us via email following the instructions.

If the file is bigger than 20 MB, you can use our Fairphone Fileshare portal to upload your files.
Please click here and follow the instructions. (Edit: Can’t provide these instructions, but if you log a ticket with FP they will as it is personal to you).

  1. Once the report is sent, it’s safer to disable again the developer options.
  • Go Settings > System > Advanced > Developer options.
  • Tap on the first toggle on the left to change it to “Off” (the color will change to grey).
  1. All done! Just go back to the home screen and use your phone as usual.
7 Likes

Thanks a lot for sharing this and I hope this problem get’s solved really soon.

Maybe you could add the link to the instructions for using the Fileshare portal for files larger than 20 MB (Point no. 8)

1 Like

Done. Apologies I copied and pasted quickly :slight_smile:

1 Like

You probably want to remove your personal details (email address, ticket id?,…) from that fileshare link.

3 Likes

Oops, good spot! I hadn’t noticed it was personalised! Doh

1 Like

Same issue (Netherlands, KPN). Reported it at Fairphone. The workaround did work.

1 Like

Same issue (Netherlands, KPN). Reported it at Fairphone.

Same issue, KPN netherlands too

Seems that the issue comes and goes on my phone. Some times it says unknown, and then later the same day it shows who is calling. ?

1 Like

Hello,
Three of my customers had the issue, but not the others… They did update their phone (FP3), they tried the two workarounds (4G/LTE; Phone settings “Caller id = hidden”) but none would work.
What else can we do for now ? Just wait until it’s solved ?

1 Like

Have you also tried the both workaround as suggested here?

  1. Settings -> network and internet -> mobile network -> advanced -> enhanced 4g lte mode
  2. Phone (app) -> three-dots-menu -> Settings -> calling accounts -> select sim -> wifi calling

AFAIK this issue only occurs when WIFI Calling and especially VoLTE is used.
If those services aren’t support by the provider, you won’t get this issue.
Also, if you are at a place where you have just 2G/3G or no WiFi reception, you won’t get this issue.
This could be the answer for @ModularKing’s question, too…

2 Likes

Hello,
One of the three called me again, he told me that he had not did the update, so now he updated his phone and it came back to normal… apparently, this person has been lucky with the update. The other two though, didn’t call back to tell me it’s good :frowning:

2 Likes

thanks Chris! however, i cannot find the things you’re referring to on my ‘dutch’ phone… could you maybe make ‘printscreens’ of the steps to take?

It might be faster, if you set the language to “English” just for repeating the steps listed in this forum.
-> Instelligen -> Systeem -> Talen en invoer -> Talen
Then select English.
You then should find your way. :slight_smile:

1 Like

Hi Cecilejl,

I have the same issue and can’t find the settings on my Dutch fairphone either, and my phone is set to English. I think it varies per country or provider whether or not we have those settings?

I reported the bug, with my country and provider, and the lack of settings for the workaround today.

2 Likes