English

Bug: Android 10 FP3 - Unknown Caller

Habe das gleiche Problem, Anrufe werden als unbekannt angezeigt

Even with new update 3A.0045 the phone numbers are NOT shown. Need to use the workaround “disable enhanced 4g lte”

BR, Toni

The same issue here, but unfortunately the sim which is affected does not have the option tot disable “enhanced 4G LTE” and I am not calling via wifi. Does anybody have another workaround?

The other sim which had “enhanced 4G LTE” enabled is not affected. Different provider though.

when I am disabling the enhanced 4G lTE mode I can NOT receive any call anymore…
when enabling it “unknown caller” - obviousely for me this workaround doesn’t for all FP3 ?

I’m using two different networks in Austria (drei and yesss) - but still this problem exist after 3A.0045 update…
:woozy_face:

A post was merged into an existing topic: FP3 - Upgrade Android 10 - Unusable phone

Suddenly my phone doesn’t recognise the numbers of the people who call me???
This week I installed the software update and system update.
Help!

Welcome to the community forum!
I moved your post here to avoid duplicate topics. Please read the solution given in the first post.

Edit: Typo

1 Like

What if your phone doesn’t have WiFi Call? It is not a possibility on my Fairphone… Strange…

You may be calling over 4G in that case (VoLTE), which was also mentioned in Chris’ post:

2 Likes

Just for the record, I also have this problem.

1 Like

For the record, I also have this problem and don’t have the option to disable “enhanced 4g lte mode”. I noticed that after disabling 4G the caller id is shown again. But disabling 4G is not a proper solution…

@gigawebs - we know, that’s why I’ve suggested it as a workaround until FP fix things.

If you haven’t already done so, report the issue to Fairphone as well and let them know the network and country your SIM is connected on. The last update on my ticket, they have developers looking at this but need this info

2 Likes

Yes, I’ve also reported the issue to Fairphone support. :slight_smile:

5 Likes

Had the same problem… could fix it. Thank you! Good support!

Hi, just wanted to let you know that for my phone (Simyo Netherlands) it got it working again with the soltion from Chris_R (sep 14), setting the Caller-ID for outgoing calls to ‘show number’ in stead of Networkstandard’. Strange that it is for outgoing numbers (al least the Dutch text says so).
Note: I have no option to disable WIFI_calling and Enhanced 4G LTE Mode…

Thx to all who contributed

Anton

5 Likes

I have the same problem, with provider KPN (Netherlands). For me the only workaround is to disable 4G altogether, which makes my internet rather slow…
My phone doesn’t have the ‘enhanced 4g lte’ of ‘wifi-calling’ mode. Also setting the Caller-ID for outgoing calls to ‘show number’ did not solve the problem. I hope Fairphone is working on an update!

Cheers
Adrian

3 Likes

I’ve used your work-around on my fairphone for the same provider as well. Works like a charm, except for the fact that I can’t use 4G anymore.

2 Likes

Have the same problem since the last system-update last weekend!!!
…and NO response from the support :rage::rage::rage:

Same problem here (but not all callers, interestingly) - habe das gleiche Problem (aber interessanterweise nicht bei allen Anrufern).

2 Likes