Broken Antenna?

Hello !

I have an issue with my Fairphone 2: suddently it has no connection to the phonenetwork anymore. (i guess it has been caused by to many falls). So did some research here in the forum and belived the antenna may have become disconnected. I did disassemble the phone to gain access but apparently the cable is still connected (top & bottom).

*The SIM card is not the problem, because it works on other phones. I also tried the move the SIM to the second slot, but the problem remains.

*The Wi-fi is still working, but worse than before (the phone loses connection more frequently).

  • GPS is not working.

  • A few days later the SD card wasnt detected anymore by the phone. (tried to format it and use another one, but nothing).

So i´m not sure if the problem is caused by the antenna or if the chipset/mainboard is slowly beginning to fail (the slot for the SIMS and the SD card are close together)

Or it might be software.

On which OS are you running? Is it up-to-date?

I’d try backing up the data and doing a #dic:hardreset, or even a reinstallation from scratch, it might help.

Otherwise indeed it could be the motherboard failing. But in this case it’s hard to solve…

Thanks for the suggestion, i´ll give it a try

As a last resort (before replacing it or throwing it out) you can re-heat a PCB to reflow and fix any connection problems. But you have to be the sort of person who likes doing stuff like that.

Update: Did the Factory Reset and the Phone worked for half a day, then it got back to loosing connectivity. So i guess its pointless to waste any more time with that piece of junke.

Got myself a FP3

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.