Bootloop fp2 after update recently (14. july)

Did you ever see the battery charging light become green?

No, it never became green.
Just fast red blinking with black screen, then boot with black “fairphone/ poweerd by android” withot led light, booting with slow red blinking, then crashing -> looping
never got the blue battery gif image.

Really does sound like a deep discharge problem. Whether this is because the charging behaviour changed with the update is another question. I don’t recall the FP2 being able to start without a battery present, so the crash during the app optimisation is likely due to the phone running out of power. The power draw during that stage is quite significant, and probably exceeds the rate at which the phone can charge. This is also why when you run the updater app, it refuses to update unless the phone is charged for >80%. Hence @paulakreuzer’s comment to wait until the light turns green - you’ll need a high enough battery charge to get the phone fully started.

There’s a more in-depth of the deep discharge problem in the topic below. As your phone needs to be able to finish app-optimisations you should definitively wait more than the 10-15 minutes indicated in the guide (rather wait for the light to become green). Try your collection of chargers and cables if you can’t get a steady charging light with first combination you try. If nothing works to charge the battery, contact support as there may be a problem with either the battery or the charging connector.

Thanx for the fast answer.
i tried several chargers, that worked fine with the phone for the last 2 month.
But I have no influence to stop/start the booting, the phone does it on its own.
What i just saw is that the phone is not beginng with the optimizing process from 1, but continues with higher numbers ( i think thats new!!).
So if the battery is really deep discharged (possible), i could just wait until all updates are with a high number of boot cycles are done :slight_smile: and then charge until 100% . That would be a unusal, but great solution, if it works :slight_smile:

Just to be sure, check whether the power button isn’t getting stuck in the pressed position - that would cause a reboot every ~ 20 seconds or so…

Just checked it, no, the power button isn´t stuck (but this would explain everything)…
i just wayt a little bit until all optimzings are done, its still working step by step.
But many thanx for the fast replies!!

Try to reach the recovery mode, this is not so energy-hungry. If that’s possible, you could try to clear cache+dalvik, to install update again. But I tend to the reason: the battery is the problem. Battery sits tight? No contact problem?

1 Like

I could finish the boot process, and iniciate the OS (select language etc.) The left the phone on in order to charge, and it crushed again. Now the red light blinks again and the FP doen´t start (couldn´t recovery mode so far)…
The FP boots on its own, but after reaching the OS iniciating process, it crashes (due to lack of energy, I think).
Battery sits thight so far (cleand all contacts).

So far nothing changed. The battery light is blinking red, the FP is getting warm, and its still in bootloop. has anyone an idea how to stop the bootloop?

Difficult to do anything if it also occurs in recovery, or you can’t reach recovery. I wouldn’t recommend flashing new firmware if the device is that unstable, it may make things worse rather than better. As attempts to fix it don’t seem to work, you’re best off contacting Fairphone support, as they’re the ones that can arrange for warranty repairs if they think it is the hardware that’s at fault. They still seem to be working on fixing a backlog in requests, so chances are you’ll get a faster response if you call them.

I’m pretty sure you need some new hardware. Either a battery or bottom module.
Someone with similar issues recently contacted support and they sent them “new parts” (I’m guessing a bottom module and a battery) for testing.

That was ME.

FP sent me a new battery and a new bottom module. The original battery seems to be OK (it’s back in my phone) but it was very deep discharged and some bottom module fault was keeping it that way - something in the bottom module was stopping charging and maybe even discharging the battery.

However, I reached a point where only the red LED would flash and only then if I pushed the USB plug hard into the socket, The phone had even stopped trying to boot. If you can get the red LED to flash all the time, then at least you have a charger connection to the battery.

You know what … we need an external battery charger device!

Support were really quick to help me (got new parts a week after posting the ticket), once I got them to recognize that I’d posted a support ticket (it had disappeared “in the system”).


Thanks for the follow-up and good to hear it all worked out. :slight_smile:
What will you do with the extra battery? Send it back? Buy it as a spare? Or did they gift it to you?

Well, the spare battery, there’s a bit of a moral conundrum. It was sent as part of a support package with no cost or return associated, legally it was a gift. I guess I could consider it as compensation for the week I had no FP2 and a donation towards the cost of my replacement UNfairphone … but I was going to buy a spare battery anyway, so I guess I should send FP €20 (and put the UNfairphone on e-bay).

Thanks for all the replies. Good that it worked for you, @nicka!
I think i´ll have to contact Fairphone support, too. I just opened a support ticket, but with that they need until a month, I heard.
I read about a forum where you can post your ticked number so it gets mentioned?

But anyway, unfortunatly I urgently needed a Smartphone for work, so I had (like nicka) to buy a replacement UNfairphone.
My wife is also waiting for the production of a new charge of FP1 replacement screens , so she will use it afterwards…

I totally agree :slight_smile:

But thanx for all your help so far!!!

You’ll find that topic if you click here: #supportrequest::tag

Hello world.
Until now I was really happy with my FP2 (hence no post in this forum), but now, I seem to have the exact same problems as rock.minister:
Battery seems low, but there’s no solid red light when connected to charger.
Sometimes the charging animation starts (w/o solid red light) but eventually stops and is interrupted by the blinking red light. Sometimes the phone starts to boot but gets black while “configuring x<30 of 160 apps”.
The FP2 Help workaround mentioned by Johannes didn’t work for me, either.
So I guess I’ll have to open a support ticket as well?

Have a nice day everybody!

Good news!
After having the battery out of the device for a day, I finally managed to get it charged today. (With the “enter battery after connecting the charger”-trick)
I deleted some of the new apps that seemed to keep the phone busy and did the latest update. So far, the device runs stable again…

Also check out this post.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.