Bootloop after Eelo update

Hello !
I launched the last eelo update this morning and my FP2 bootlooping since. Is someone has the same problem or an idea ?
(please excuse my english :s)

You might try a manual reinstallation as mentioned here:

Just don’t do any format or wipe during the process (it might help against your bootloop but would lead to a final loss of data on your phone)!

Thank you for your answer. So, you think it’s better to do the entire installation process again ?
When I try by TWRP (a factory reset or even wipe (I tried before I read your answer)), it’s the same bootloop. Do you think that if I overwrite everything with a new installation, it will work ?

Edit: That tip is for FP3, sorry, hadn’t read properly :slight_smile:

Before reinstalling the OS, you may want to have a look here:

1 Like

Well, now that you’ve removed your data anyway: did you also do a “format” in TWRP? It might also help.
If all this doesn’t help a reinstallation of the OS should do it. If not you might also try out a different OS.

1 Like

Maybe, although it’s a FP2 here…


Whoopsi… Ok, sorry, hadn’t read properly :man_facepalming:

1 Like

Thank you for your answers, I did a format and an advanced wipe, but now I have a new issue : “No OS installed” and I can’t mount my FP2 on my computer : “Cannot open the MTP device”, so I can’t put eelo on it.
I tried with ADB transfer, but that didn’t work.

edit : Finally I can put the .zip on my sdcard but even if I make the install, when le FP2 going to reboot it write “no OS installed”…

Maybe you follow this guide now?

1 Like

Did you try to reboot nonetheless?
This warning has often been observed to be a false alarm by TWRP. It’s not known (at least I haven’t seen anything up to now) why TWRP gets this wrong sometimes, but you don’t lose or break anything by just trying to boot. Either it works regardless of this warning, or you have to go back to TWRP and continue trying to do what you were trying to do.

1 Like

I try to do the install by follow the guide but that doesn’t work. It still booting on TWRP…

Yes I try, but it boot on twrp

1 Like

You might start with a “manual install” of FPOS:

This is not what you want but it might be a good start at the present sitation of your phone…

I did the fairphone OS installation, but when I reboot it said “System UI has stopped” and I don’t have twrp anymore.

But it booted, that’s a good thing.
Fairphone OS doesn’t come with TWRP and installs the stock Android recovery instead, but you can install TWRP again yourself …


Then you can again wipe data partition (and not the system partition) or do a factory reset on the recovery which comes with FPOS. Then the phone should start normally.


Thank you so much Volker and AnotherElk, that worked !


Good to hear that your phone is working again at least! :+1:
So with the experience you had you’ll stick to FPOS for now (or do you feel more experienced and more adventurous now)?

1 Like

No, I’ll stik to FPOS for now ^^