Boot loop while charging


My FP2 ran out of battery, so it automatically shut down.
I pluged it to charge with my usual charger, except after a few minutes, it automatically tried to boot.
It then shut down again (I think it had not enough battery charged to power on), and tried to automatically boot again.
Then it shuts down, then tries to boot, shut down, tries to boot, and so on, for an infinite loop.

I tried different chargers, I tried removing the battery and placing it again, and the problem is still the same.
The first boot goes up to the screen with the three blue dots (sometimes not even that far), and the following boots, just shut down at the first Fairphone logo.
I didn’t do the last update yet, so I think I’m running Fairphone OS 17.08.1

I couldn’t find any post with the same issue, so any recommandation is welcome :slight_smile:



Note : I tried plugging it without the battery, and the same issue occurs (except for the few minutes wait), so it is most probably not a battery related problem.

1 Like

Try the following:

  • #disassemble the phone
  • take off the screen and take out all cards.
  • put the battery back in
  • plug it in
  • the LED should light now (:warning: it’s brighter than with the screen on), unless you were on Lineage OS maybe

This way (without screen and cards) charging should definitely be faster than discharging, so after some time you can boot normally again.



It was smart idea, but it is not fixing the problem.
The phone keeps loop booting even without the screen and cards…

Well then I don’t think it’s (primarily) a battery/charging issue.

I’d still try to charge the battery like that for a while (without the screen even rebooting may not use up more energy than you are charging at the same time) and then try to get into #dic:recoverymode to perform a #dic:hardreset (which will erase all your data).

Well, letting it charge fo a while doesn’t change anything…
And I can’t boot it in recovery mode, it just doesn’t react…
I guess I’ll contact the support
Thanks for your suggestions :slight_smile:

1 Like

Hi Freshgale I have the same problem I try to flash updates for OS and all continue equal.

(as a hint: I see that last time Im in the OS the battery are always on 50%…)

You solve it?

No, I didn’t solve it…

The issue fixed itself over time, but re-happens everytime the battery drops to 0%. Every time it happened, it usually took between a few hours and a few day before I could manage to charge it properly without the phone looping.

It has been 3 weeks I didn’t get any answer from the support, and a few days I can’t use my phone, so I sent a new message to the support… If they don’t answer soon, I’d like to call them, but I don’t have a phone anymore…

Next time it drops to 0% (it is actually strongly recommended never to), please take it out of the phone for at least 30 minutes, then see if you can let it fully charge without switching the phone on (“Battery Reset FP2” as detailed in the #batteryguide).

And the bootloop when connecting the phone to a power socket without the battery in the phone is normal. It indicates that the charging port works.

It’s been 3 weeks I can’t use my phone, trust me I went through all recommended manipulations that I could find on the forum, including Battery Reset… :wink:

Also I know it is not recommended to not let the battery drop to 0%, but the phone often doesn’t charge while turned ON. And when I shut it down, the boot loop issue happens, so I’m kinda stuck.

Thanks for your tips anyway :slight_smile:

Hello Fresh,

Some weeks passed since your problem appeared and i was wondering if you found a solution yet that you could share with the community. since i too have the same problem.

Also how did you charge your phone with the boot screen constantly showing? How did you know when it was done charging? My fp2 led that should indicate if my phone is (being) charged does not work either.

thank you for any idea or solution!

Best, miamiamoto

This is the usual reaction when being hooked up to a charger but without battery inserted.
Maybe the battery contacting is faulty.
Charging up your battery from 0% will require a charger strong enough to overcome the initial charge current. Usually 1 amps output is sufficient for charging even when switched on, but may not be sufficient for this demanding initial moment even when switched off.

Update here quite a while after. (sorry for the delay)

I contacted the support, and first, their diagnostic was that the battery was failing. They sent me a replacement battery, but it didn’t solve the problem.

I contacted the support another time, and they sent me a replacement bottom module, and now my phone is charging just fine.

tldr; broken bottom module, get a new one.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.