English

Bluetooth issue: device refuses to be paired

Hi, it’s a weight device (Salter Mibody) and it’s perfectly recognized on my Android Tablet.

It doesn’t show up in the application but it does show in the bluetooth add device screen, but it refuses to be paired.

Anyone else with that issue?

I have a new FP3. All seems to be working except Bluetooth pairing. I’ve tried with a couple of devices (speaker, watch) and neither will pair. Did you get any solution or fix to your problem?

OK, Bluetooth is now working with my separate BT speaker. I switched off the BT connection on our iPad and other phones so that I only had BT on my FP3. The FP3 did then connect so I’m presuming it was to do the other gadgets on BT and it wasn’t any FP3 defect. I just updated this in case the info is of any use to anyone else. Thanks.

3 Likes

Sorry, what? I only have BT on the FP3 and the other device…

I was just saying that I had a similar problem to you. But it’s now working since I disconnected my iPad from Bluetooth which may have been interfering with the FP3 connection.

1 Like

Still getting device didn’t accept connection. :stuck_out_tongue:

is there any other gadgets on bluetooth that may interfering with the connection? (… I’m not an expert, it’s just what worked for me).

Is there a thread with a list of compatible devices?

I have been using my smartwatch (Samsung Gear Sport) and my (new) Fairphone 3 doesn’t connect to it. The pairing worked and I can see the smartwatch on the list of “connected devices”.
But neither directly after pairing nor any time later I could establish a connection between phone and smartwatch to transfer any data.

I’m afraid there are only some certain devices which are compatible - and my phone isn’t one of them…

Hi C.S, did you find a solution? If yes, could you please explain how you couple your device. I am faced with a similar problem. My Fairphone 3 recocnizes my Galaxy Fit watch but unfortunately pairing is not possible.
Best regards Francesca

Sometimes there’s interference of the bluetooth on 2.45Ghzconnection, maybe when one device has a weak signal. To help avoid that you can switch off 4G network (2.3Ghz or 2.5Ghz and wifi 2.45Ghz the later uses the same bandwidth, so does your microwave if you have one.

You could try switching to aeroplane mode while you connect which will help if it is a signal issue.

2 Likes

Just a guess:
There are some devices which need the Bluetooth Low Energy feature. Fortunately there is the Corona App debate so I learned that one is only fully functional with location services switched to “on”.
Thatway I was able to connect to a Wahoo Speed+Cadence meter, a Pokit Current+Voltage meter and to have the German Corona Warning App active, running and searchable by RaMBLE.
I have no experience with Smartwatches, but it would sound valid for me if they would use BLE too in order to keep energy consumption low. So I think it is worth the shot :+1:
I paired those devices without location services (and they were connected but non-functional) and I think I did a full re-pair after I switched location services on…

3 Likes