Bluetooth automatically turns on after (re)boot

Is there a way to set bluetooth so that it’s off until you turn it on with the button? I seldom use bluetooth and it’s unfortunate that it wastes battery power when I’m not using it. As it is, I have to pull down the menu and turn it off everytime I start the phone.

2 Likes

Ah, that’s why my Bluetooth was on after installing and rebooting into the latest update :slight_smile: I cannot find any setting that can control this behavior. It might be hard coded in the Fairphone ROM.

Couldn’t find it as a default option, but apparently it is context based and Flight mode will not switch off Bluetooth if it is paired.

I have Android 11 on an FP3 and switching off the phone with bluetooth off results in no bluetooth on reconnecting.

However switching off with bluetooth enabled means it’s enabled when I switch the phone on.

That’s the same with my FP3 with Android 10

I’ve actually Bluetooth disabled at the moment. When I reboot it’s still off, but after 5 seconds or so after unlocking my phone for the first time, Bluetooth is suddenly enabled. It would be nice if the phone respects the last known state of Bluetooth when the phone was last on. So if it was on when rebooting, it’s on when the phone turns on again. But if disabled, it would be nice if it stays disabled.

Maybe you have some app that enables it ?

Could be, but if more people can reproduce this, then I think it’s a builtin feature.

1 Like

When you disable Bluetooth scanning in the settings it doesn’t auto enable Bluetooth anymore. I still consider this a bug. Because I don’t see this behavior on my Pixel. The option description also notes that scanning may occur even with Bluetooth off. So there is no reason it should be on all the time. Android can simply scan whenever it needs to. WiFi doesn’t automatically turn on when rebooting while having WiFi scanning enabled.

1 Like

Thanks for showing that setting, something I wasn’t aware of. :slight_smile: Now I can have both of
:vulcan_salute:

1 Like

Where is that setting? I can’t find it on my FP4.

I had to search for it :slight_smile:

Settings → Location → WiFi and Bluetooth scanning

But you may also find it when searching for “Bluetooth scanning” in the search bar in settings.

3 Likes

Thank you! I found it.

2 Likes

@Ninni & @amoun which carriers are you using? Fairphone support is wondering if this is due to settings pushed by a carrier. I suppose if you have diverse carriers, it’s not that likely a bug triggered by a specific carrier.

1 Like

I’m using EE UK . . . .

1 Like

It doesn’t happen anymore, since I changed the setting for Wifi and Bluetooth scanning.

True, but that’s a workaround, it still needs to be fixed :slight_smile: With the carrier information we can at least pinpoint the cause and find a solution.