Black screen for incoming calls

I had put some hopes to the last update, but unfortunately - no real change :frowning:
But at least I discovered a work around:

  1. Someone calls - the screen stays black
  2. Push the right top button (“power button”)
  3. The screen turns on
  4. In the center bottom of the screen a button turns up stating something like “go back to current call”. My telephone speaks German and states “Zurück zum aktuellen Anruf”
  5. Push that button
  6. Get to the usual swiping screen where you can either take or reject a call…

Nevertheless - getting back to the original status would be great :slight_smile:

@Ivar, I don’t even get on your 3th step. If I push the power button, the screen turns on, but the call stops. So I always have to call back.
Hope a solution come quickly!

Sounds like your power button is configured to decline incoming calls when pushed.

Hi Paul!
My screen isn’t black, I can use my phone in the same time it’s not the same issue, i think…

Oh sorry, then I misunderstood that sentence:

Maybe it’s a different issue, but maybe it’s just a slight variation of the same issue.
If you want I’ll move your post (and my replies) back, but I guess chances are high that both issues have the same root cause and therefore the same solution.

Hi Paul !
It wasn’t the same probleme but I found my answer here !!
I don’t know how but the “phone app” was on no notification, it was for that !

So thanks !!


It works for me as well! Thanks @t_eowyn for the tip :slight_smile:

1 Like

@Ivar, @rk1966, @Stefaan_Coutereel did you try @Johannes’ tip yet?

@FlavieC if this solves the issue for them too please update the bug report.

3 posts were merged into an existing topic:

A post was merged into an existing topic: FP2 Screen can’t be reactivated during/after calls - See first post for Workarounds

I can hear an incoming call, but the screen does not react. I can’t answer the call! Help me. It’s not the proximity sensor.

Problem solved! Yes indeed, a permission/notification issue. Thanks a lot to everyone !

1 Like

It works. I’m impressed! Thanks @t_eowyn @FlavieC


I tried it yesterday - it worked!
Thanks a lot for the hint and all the constructive and quick feedback! :slight_smile:

1 Like

Thank you. This worked for me. On my phone, the ‘phone’ app is called ‘Telephone’ so it took me a while to find it. Cheers.

1 Like

Oh thanks a lot! Mine had that issue. Works fine again
But weird… I didn’t activate that! It worked no more since last update. Thanks again

1 Like

Worked for me as well. Though I also did not change the settings. Thank you for the help!

1 Like

Hi, thanks for this suggestion, works perfectly now!
Just strange because I never checked this “no notifications at all”.
Must have been a bug in the new update… @ you Fairphone guys, please check if with the new update the phone app was automatically not allowed to show notifications anymore. If so, please fix that, thanks!

As this happens to people since june semingly randomly it’s probably not a bug caused by updating.

I was also seeing this same problem (no accept / reject popup on an incoming call, only a small “return to call” button in the lock screen, which would switch to the accept/reject popup and allow accepting the call). For me, the phone notification settings (Settings -> Apps -> Phone -> Notifications) was indeed set to “block”, so switching back to “normal” is probably going to fix this problem (haven’t received any calls so far to test, though).

For me, this behaviour started on a random moment, not correlated to any software update, a few months ago (I can’t remember exactly when, though I think it was later than june). I was running an older FP open beta versions (still the one from the Marshmallow release party at the FP office I think) and thought that was it, but upgrading to the most recent FP open this week did not solve it. Yay for this topic, which (presumably) did solve it :smiley: