Being multi lingual

I searched for the issue i have at the moment, and it seems this thread is very similar:

But in my case, i do not have the world-button shown on the screenshot next to the space bar.
Is this related to version 1.6 (which i have) and maybe the person owning the phone in the screenshot has FP OS version 1.7?

How can i switch between languages in conversations (whatsapp for instance)? and if this is not possible, why not? i had an archaic android 2.3.5 phone that could do this, for N number of languages :frowning:

I don’t want to go all the way to the settings menu to change global phone language every time i chat in English, French or Spanish ;(

Thanks for any help

The world-button is only visible if you have multi-languages selected.
Go to System settings (the button far left below on your phone)
under the sub PERSONAL tap on 'Language & input’
under the sub Default tap on the icon right of 'Google Keyboard’
tap on 'Input languages’
now tick the languages you need (I have Dutch and English)
In Messaging and in WhatsApp I can just change the language by tap on the world-icon.


Ahhh so this is how i do it. I was searching high and low trying to find out how to do this!
Thanks, problem solved :smiley:

Do you refer to this post of mine?

It shows the default keyboard of Fairphone OS 1.6, without Google Apps installed. Below the screenshot, there is also a description how to get the world-button.

1 Like

Good to read that it is possible to easily change the language when typing.
I followed the steps mentioned above, but no globe-button appears, even after restarting. Anything new that needs to be added to the steps?

The steps above should still work. Are you sure you’re using google keyboard? When you have a keyboard visible, you should be able to swipe down the notification area at the top the screen to get to an option called ‘Choose input method’ (under which it lists which keyboard you are currently using). This should allow you to switch between any of the keyboards available on the system, and also allows switching between languages in the google keyboard.

Edit: If you are sure you are using google keyboard and have multiple languages enabled in the settings, check under ‘Advanced settings’ of ‘Google Keyboard Settings’ for the ‘Language switch key’ option. The default is to show the switch key.

1 Like

Yes it works!! Sorry, tried to fast the first time, saw something with ‘google’ and ‘keyboard’ and just ticked it, but it was the wrong option.

Oh it’s so heavenly to not have to change every word anymore!
Thanks for replying

1 Like