Battery life in LineageOS

Hi. After LineageOs I installed Greenefy app too. Now I have an autonomy of 2 days (!), despite having downloaded the cards of Osmand ~ and Sitytrail.


impressive. i will give it a try to greenify, any suggestion in the setup? are you using wi-fi when sleeping?

I started with full automatic setup, I bought the paid version a year ago. Now I’m trying personal settings, to make Waveup and MacroDroid more responsive, and autononomy is less impressive.
I’m not sure I understand your question about Wifi

I want to share my experience nearly two weeks ago I installed the 14th.Aug OTA update and uninstalled Greenify, as it was mentioned that

Pretty much right away I left the country for a weekend break. So the FP2 was on roaming with data roaming deactivated. I haven’t rarely used the phone but it was almost always connected to a very slow wifi. Network strength was mainly bad. Surprisingly the battery lastet for 1.5 days, I couldn’t belief it. This led me to the assumption that the problem is strongly related to the availability of mobile data usage.

As I returned home I tried to reproduce it but battery lastet mainly for less than one day.
During the last days the battery has been able to last for more than a day and this time I have got some BBS stats (logs area attached but you have to remove the .pdf extension) as BBS doesn’t store any data it only reads the logs since the last boot up. I’m still running on BASEBAND VERSION 4436.1-FP2-0-04 and haven’t deactivated Keep Wi-Fi on during sleep.

Besides this I noticed that the battery level is not the same when the phone is being charged and switched of and the level indicated when the cable is unplugged and the phone startet. I assume a recalibration is needed but how?
Can we agree here on common method?

FYI There might be alternative for BBS, what is explained on PROJECT BETTER and on AllianceROM in a nutshell. Batterystats and Battery Historian Walkthrough on Android Studio, what seem to deliver better graphics/trends.

Here are the screens shots, when it’s too much I can remove some.

  1. 24.Aug.17 - expected battery duration 1.5 d - roaming but data roaming off, WIFI in sleep on

  2. 24.Aug.17 - almost dead after 28 h - roaming but data roaming off, WIFI in sleep on

  3. 25.Aug.17 - 1d later, expected battery duration >2d - roaming but data roaming off, WIFI in sleep on

  4. 25.Aug.17 - expected battery duration 2d - roaming but data roaming off, WIFI in sleep on

  5. 30.Aug.17 - expected battery duration 21h - back home, WIFI in sleep on, mobile data off

  6. 01.Sep.17 - battery duration 33h - back home, WIFI in sleep on, mobile data off

  7. till 05.Sep, around 20h battery duration - back home, WIFI in sleep on, mobile data on
    no screen shots

  8. 05.Sep, expected battery duration 33 h - back home, WIFI in sleep on, mobile data on

    BetterBatteryStats Screenshots: (SPIEGEL App is my all morning newspaper, that’s why it pops up)

  1. Unplugged - Summery

    2 ) Unplugged - Wakelocks
  2. Alarms&network
  3. CPU States
  4. Process&Sensors
  5. Graphs
    the same as Raw Stats:
  6. Raw Stats - Summery & Alarms
  7. Raw Stats - Wakelocks
  8. Raw Stats - Network & CPU Stats
  9. Raw Stats - Process & Sensors

logcat-2017-09-06_122649292.txt.pdf (86.7 KB)
dmesg-2017-09-06_122649438.txt.pdf (123.2 KB)
BetterBatteryStats-2017-09-06_122649025.txt.pdf (215.9 KB)


I can confirm this observation. Last weekend I was in a place without mobile network. So I switched off mobile data. Wifi was the whole weekend on.
Battery lasted much longer than before with mobile data on and wifi off.

So it seems that could be a reason.
In addition I interesting that we have here two opposing statements

1 Like

Because it depends how you configure greenify. But normally it does not kill the app but tries to suspend it


@lklaus & @cortomalese, how do you think about creating a separated thread focusing only on the proper configuration of Greenify on FP2 LineageOS? That would keep this thread a bit cleaner.


I put the logs on pastbin:

Why not? Maybe some other people are interested

Puh, yes I am also running out of battery quite fast. I have installed the latest test build, because I am expecting the new camera module :grinning: But things going even worse. Capacity has been about 44% when switching off wifi/ network and going on fligth modus over night. Result this morning 14% battery capacity … :hushed:
I will switch back to FP Open, because I am going on holiday tomorrow…

1 Like

For the record: I’m on the latest test build (new cameras) + Open GApps pico and my battery holds up totally fine, at the moment I don’t see a difference to my previous Fairphone Open OS + Open GApps pico installation.

If somebody could give me a summary of test cases or what settings to check for comparison, I could check and report back.

Could it be that batterydrain is more related to the display? I read in bugtracker that the last change in august was related to display blobs(?). I run my phone always on the lowest brightness but still the battery use from display seems relatively high!

About Greenify: I have started using it under FPopenOS and it seems to help. This article may be of interest:


see here: Greenify on FP2 LineageOS


in regard to Greenify please post in Greenify on FP2 LineageOS

1 Like

So I installed greenify now and all of a sudden I have amazing battery time, better then ever before since I have the phone!!

1 Like

I reinstalled Greenify but don’t see significant improvement. I use the free version since I don’t see any advantage in the extra futures as most of them need Xposed (what is still in Beta):
◆ Allow (most) system apps to be greenified in Greenify
◆ Boost mode (requires Xposed)
◆ Allow GCM push message to wake hibernated apps (requires Xposed)
◆ Reveal hidden sync tasks (requires Xposed)
BBS isn’t that much if of help since I cannot compare certain time periods. Enabling the watchdog feature is a bit of help. I noticed that

  • msm_ehci_host
  • PowerManagerService.WakeLocks
  • PowerManagerService.WakeLocks

causing the majority of wakelocks.
The WiFi is still always on I don’t want to have it swiched of in deep sleep than I won’t receive any messenger/mails etc. notification. Any idea how to switch on the WiFi in deep sleep in periodic steps to check for new messages/mails?

For a very short moment I was optimistic that the battery is back to long running periods but as I left home and consequently switched to mobile data battery was dropping as usual even as I was connected to my office WLAN.
I would like to compare that period with a later period but I don’t have a clue how to do that.

I was doing some observations with bbs (idle dumps). There i got an average battery drop around 1-2% per hour, which is much compared with other devices getting an average of 0.5-0.7% per hour… The msm_ehci_host is supposed to only be leveraged in the kernel. It’s either sd card or wifi, according to a Google search (would have to check which device is hooked to this subsystem/usb hw).
Still, i got my battery usage somewhat mitigated. I switched from greenify to forcedoze, but am still undecided whether this move helped.
One this i see in your battery stats is that you had very bad mobile coverage, this will drain battery…

I continued with my test as battery drain is really frustrating.
First of all is there any alternative to BBS as I want to extract data for a set time range, so far I found
GSam Battery Monitor and Watchdog Task Manager Lite but don’t know anything about them.
I’m saying that since I’ve noticed once that battery drop trend was quite flat as I used in the morning as every morning than I went to work and logged in the local Wi-Fi but as I left home battery drain became much worse and it didn’t improved as it was connected to a Wi-Fi again.
What would help me a lot would be a possibility to compare wakelocks etc before and after I went to work as I didn’t trigger anything actively.
I even restrict mobile background data to three apps.