English

Battery drains within half a day (phone always „awake“)

I made no conf change between the two states and I’m suddenly experiencing a short battery since update to 16.08 as detailled here : [not the right link. Lost the right link]

The easy thing to do is check if the area on the backside of the phone close to the camera feels warmer than the rest of the phone. If so, the CPU draws a lot of power, so you’ll want to hunt down the app or background process that is running a lot. If that area does not feel warmer, chances are that your battery is no longer having anywhere near its design capacity.

It’s more likely tho that there is a hyperactive app. There are some apps that will give you an overview of the CPU’s load and which processes are most active, e.g. “OS monitor”.

I had the exact same problem (battery would last only 8 hrs or so) and in my case, the problem was fixed by clearing Gmail’s cache, which had grown to 1GB,.
Go to "Settings -> Apps-> Installed Apps -> GMail (or any other app you find suspicious in os monitor) -> Cache -> empty cache
(all menu lables re-translated from German, sorry),

In OS Monitor I also saw high activity for an “SDcard” process, perhaps GMail was trying to extend the cache to the sd-card. Anyway, I’m back to 2+ days of battery life after emptying GMail cache.

1 Like

I a first move, I thought that it might be the battery level reading software which may have dysfunction since the update. But the phone really shuts down when it reaches a low battery level, and its long to refill it afterward…

https://forum.fairphone.com/t/fairphone-open-16-08-0-is-now-available/21973/61?u=s99h&source_topic_id=21885

For me it’s definitely using the proximity sensor that’s causing the phone to not go to deep sleep. And it’s definitely started with 16.08. Before i had no such problems. Also, i also have the impression that battery drain is higher. But according to bbs it’s mostly Google, so probably it’s not fp oos to blame

That’s indeed the case. The battery often feels warm and the “awake” mode shown in my screenshot does also indicate that a certain app is responsible/process is responsible.

Thanks for all your suggestions. Unfortunately none of them helped - i.e. neighter emptying the cache nore disabling GMail helped. Furthermore, did I have those problems from the very beginning (also before the Fairphone OS update) and they still remained directly after a factory reset.

That’s exactly what I was basically asking for: how can I track down the responsible app/process???
I had problems installing “Wakelock Detector”, because of the root permissions required.
“OS Monitor” shows a CPU usage always >50%. Number one is always “System” (which strangely says: Processes: 0).

Any help on this is greatly appreciated!!
Does anyone know how to find out which process is exactly responsible for the heavy CPU usage?

Thanks already

It’s really hard to do this if you are not rooted (as you already found out in your first post). I can only point you to a thread where we hunted down a wakelock I had on my FP1:

What really bugs me is the way the battery usage can mysteriously speed up overnight. For instance, last night before going to bed the Settings told me I had 12 hours left on the battery. It went flat in less than 6 and I missed my alarm call.

IMVHO it seems to me to be a failing of the Fairphone that it has to remain on all night to work as an alarm clock. Whereas with my old Nokia I could set the alarm and switch it off, and it would automatically switch on with the alarm.

I don’t know how to reproduce the battery usage chart here, but here are the stats:
Screen 10%
Wi-Fi 9%
Email 8% (this is the generic app, which I have abandoned in favour of Outlook: Emails from Fairphone haven’t been sent )
Phone idle 3%
Google Services 1%
Mobile standby 1%
Android OS 1%
…which leaves 67% unaccounted for!

I´m using the free Ampere app from the play store to show me a more specific glance at the actual current flowing while charging/discharging. Everything higher than -150mA discharge current in idle seems to be to high if wanting to have a longer lasting power reserve. It does help using the battery saver and also switching off wifi and data usage and furthermore closing all apps not necessarily needed. Very often people underestimate the influence all this takes on your battery availability. I keep two sim cards and another sd card.

;

(Location service is off, but icon still shows)
It could be interesting having a competition on "how low can you go - longest uptime without recharging… P-)
My overall power drain got better with my first update to 1.2.8. Now I´m running FP OS1.7.0. You should at any time try to close or quit google play store/service or whatever called google play. This app starts up at any time it feels using any available data connection for whatever data transmission even if you are not thinking of dealing with the playstore at all. It surely spends a noticable amount of your data volume and also leeches out your battery. I´m using the so called “Noroot” firewall saving me reliable from loosing to much of my data volume and also keeps off too communicative apps/system processes from spreading background data at any time. Don´t want to miss this firewall anymore.
Of course being permanently available by wh***app, having synching to any cloud service active, emailing, wifi, data usage, location or permanently scanning for other networks will run down your battery quickly even if not phoning to much.
Take a close look into the apps permission requests (new ones and already installed ones). Very often there is a requirement below the [other] paragraph saying “prevent phone from sleeping” Keep a critical eye on these permissions and realize what´s actually going on not having to wonder why the battery is draining so quickly. It´s not necessarily always the cause of an update. But it´s more convenient to put it that way.

You could turn off the FP1 overnight and the alarm would still go off. But, as you say, that seems to be impossible with the FP2. I think maybe this merits a new issue dialogue. Or maybe there is one. I’ll check.

Since I updated to FPOS 16.08 one week ago may battery is draining fast. I do not have google apps and I did not change anything, how did you solve this problem?

https://forum.fairphone.com/t/use-of-proximity-sensor-drains-the-battery/22155/4?u=s99h&source_topic_id=21885

I believe it was WaveUp. An app that uses the proximity sensor to wake up the display.

I did some tests and I think it’s more likely a WaveUp, than a Fairphone OS problem:
https://forum.fairphone.com/t/use-of-proximity-sensor-drains-the-battery (scroll down to my post from today)
https://gitlab.com/juanitobananas/wave-up/issues/79

Here, i don’t use waveup… I’m using the proximity sensor with different apps…waveup is not on my phone

I unmounted the SD card, removed a few old podcasts, cleaned the dalvic cache, and this morning the battery level was the same as ist was the night before (I turn wifi off and leave it in airplane mode o.n.). I have not the Waveup app, but Gravity Screen which worked fine all this time. So, it seems the big SD card could have been the problem in my case. Thanks for your tips!

1 Like

Keep an eye on Gravity Screen too. Does it make use of the proximity sensor for waking up your phone or for switching off the display?

The proximity sensor is an option, but I have it partially disabled so that the waking up of the phone relies on the gravity sensor. It is working fine so far.

But you are right, wenn the proximity sensor is on (even partialy), the battery drains rapidly. This is new since 16.08, it was working fine before update.

Please continue here:

https://forum.fairphone.com/t/use-of-proximity-sensor-drains-the-battery/22155?source_topic_id=21885