Battery doesn't charge from AC but it charges from PC or external battery

I’ve been having problems charging the battery of my Fairphone 2 since five days ago.

First day I plugged in my Fairphone to the AC with 40% of battery or so and after a few hours without using it I realised that the battery charge instead of increase had been decreasing faster than usual. I had to go and I couldn’t try to charge it again until the charge was completly empty, and that time it charges perfectly.

The next day I plugged in my Fairphone when it was at 15%. It happens the same, it didn’t charge and the battery decrease really fast. I tried with two different cables, I switched off the phone and I couldn’t turn it on again (I guess it was because the battery discharged completely). I spent almost an hour trying different things. When I plugged in it, the image of the inside of the Fairphone with the battery charging appears in the screen but just for a few seconds, after that the screens went black again, but with the red LED light. After an hour it suddenly started to charge ok again.

That night I plugged in it with a 48% of battery. It seems to be charging (the battery icon had the lightning symbol), but when I wake up in the morning my phone was off with no battery charge at all. I plugged in again and it charged a little bit (I had to go). At the afternoon I pluggen in again to AC and it doesn’t charged, so I tried connecting it to a laptop and it charged perfectly to 70% (I had to go before the charge was complete). At night in a friend’s house I plugged in again to AC and it charged to 100%.

Since then I haven’t been able to charge the phone with a charger with an out of 1000mA (AC and a solar charger), but it charges perfectly with lower current sources as a laptop or a external battery. When I plugged in to AC, I see the lighting in the battery icon and the red LED light but if I go to Settings -> Battery I see: 40% - Battery is not charging (or the percentage it has)

I don’t know if it could be a problem from the battery or from the software. I tried with three different cables, and some of then are the same I use to connect to the laptop. First day it happens before the last OS update, second day I update it and still happened.

My Fairphone 2 is one of the first bunch so it is exactly 1 year old.

Any suggestions? What should I do?

1 Like

More or less the same is happening to me since last Friday.

Same FP2 bunch. I made the last OS (1.11.1) and apps updates in the morning and by the end of the day, when I tried to charge, same problem with the same symptoms appeared. Except that mine is not even charging with a laptop. I could’t try with an external battery yet.
I have two batteries. It is happening with both of them. I could charge them perfectly in friend´s FP2. From that I would discard battery issue.
I also tried with different cables, AC chargers, computer… No difference.

I contacted yesterday the Support Team and they are lost. One said it should be the USB port. Another one want to look at the battery slot pins. Both agree it has to be a physical problem.
I still think it is a software problem. It is very strange that it reacts different when you plug it while the phone is off or when it is on.
I’m trying now to downgrade the OS to check my point.

I will update as soon as I have news.
May the Force be with me :stuck_out_tongue:

1 Like

@KimiGuti

It need less power/current when switched off than when booted and running (apps) in the background. your power source will recognise the different consumption.

It could be that your phone suffers from bad battery contacts. To exclude any misbehaving app or service running mad keeping your cpu at max level perform your charging tests while the phone is switched off.
Then you should find a setup with which you can accomplish a full charge. Try different cables, chargers, computer usb outlets. Maybe also try what´s explained here: "Loose battery of FP 2 causes many problems! Check if your battery is inserted tight!"
I am not sure if it could be a problem of the bottom module, because it would not make any difference which power source is used. I think trial and error is the only option here. Good luck.

Hi!

Thanks for the answers.

My phone doesn’t react different when is off or on. I’ve just tried the following:

  • I switched off the phone with a 51% of battery.
  • I plugged in to an AC current.
  • In the screen appeared the image with the battery filling up so it seemed that it was charging.
  • I left it like this about ten minutes,
  • I unplugged the phone and switched it on and it has a 25% of battery!!

I also think it is a software problem. A hardware problem that makes the battery discharge faster when it is plugged in makes no sense for me. I was thinking to restart the phone to factory settings, but I need to have time to save all the data, so I didn’t yet

I guess it should be a link but it’s not… Anyway, I extracted the battery and inserted it again and nothing… And I don’t understand how it could charge connected to a laptop if it would be badly inserted.

One more data is that the other day I tried to plugged in to a PC and it doesn’t work either. I don’t know if a PC provides more current power than a laptop.

1 Like

It´s a topic in this forum to search for btw.

I had this behavior at the beginning as I only had an old weak charger not strong enough to deliver the needed current for FP2.
It showed up as it would be charging the battery, but too less current was provided actually keeping it draining.

My phone also is one of the early. No. 9601 but with each update there were improvements.

Reducing the power consumption to the minimum is when the phone is switched off. If charging then does not work properly up to 100% there is hardly a chance for any other software taking influence.

So there may only be hardware options left such as charging cable, charger itself (weak source as old usb 2 options whether notebook or desktop pc), maybe defective bottom module or battery itself.
In this forum there is also a tutorial of how to do a battery-reset. Maybe it helps.

1 Like

Thanks for your help.
What you say as a lot of sense, but the thing is that although the phone is behaving differently when on or off, in no case is charging the battery. I tried with different chargers, cables and in all “setups” I could. (also rebooted without any app installed)
No loose battery in my case either.

Hi hi!
I finally restarted my phone to factory settings, but the problem was still there.
To my surprise the factory settings option, wipes all data from the phone but it still runs the 1.11.1 OS version!!

Still trying to test the Software theory, I tried to install manually the 1.10.1 OS version but the phone gives an error due to the fact that a newer update is already installed.
I contacted again the support looking for a way too downgrade the OS and they couldn’t help me.

Then I came to a way to downgrade the OS by myself!
First I installed the Open OS.
After that I came back to the Official Android OS, but it is the 1.10.1 version.

Result: negative :frowning:
The problem of charging is the same and still there, either with the Open OS or the OS 1.10.1, with and without apps.

This ends the software theory :sweat::sweat:

Still in contact with the support team, I will try to swap bottom module with the phone of a friend, to test what happens.

To be continued…

1 Like

That was to be expected as otherwise the phone would always have to keep two firmware images to fall back to the initial version.

This actually does not put a positive light on the support as it is the customers “last” option before returning the device.

Indeed, nice idea. :wink:

Quite obvious, unfortunately.

So there comes the benefit of modularity, but anyway an annoyance to figure out the cause.

Good luck.

1 Like

Thanks! we will see :+1:

1 Like

Update of the charging issue:

Yesterday, after I did the update to the OS 1.12.0 my phone is charging again als normally! :astonished:

I was right after all. The cause was the OS update. The software. I have no idea why, but so it is.
I agree that it has to be something wrong with the hardware, since this is a rare case, but it is definitely activated or deactivated by changes in the programming.

We don’t know much more about this issue than we did at the beginning, but by now my phone is charging again normally through the cable, which is a good thing :blush:

2 Likes

Many thanks for your feedback.

I thought all initial charging issues were solved by now.
I remember with my first charger and the first OS version which was delivered with the pre-ordered phone batch my phone would not charge but only on the pc.

After the first update my problem was solved as stated in the change log.
Meanwhile there is a list available in this forum of FP2 compatible chargers.
But it is indeed strange that your phone showed such a behaviour which at last was cleared with the update.

1 Like

I’m sorry for not answering first.

I think finally my problem was the charger… I think there are two chargers at my home which are broken, and I think that when I tried it with my charger and then with another one which was ok, my phone continued to behaviour in a strange way.

Now it’s charging perfectly with another charger, but still no with mine.

2 Likes

I’m glad to hear that you found also what caused your problem.

Cheers

I am having a similar problem. Since a few days ago, my Fairphone 2 no longer charges while on AC power. So long as it is on AC, the battery will discharge but not recharge.

It was already the case that the device would not recharge when connected to my Macbook Pro via a USB cable. That was odd, but there are so many ways around it that I didn’t care.

Right now, my only way of charging the device is to connect it to my powerbank (using the same USB cable that won’t help me when it’s used for charging from my Macbook!).

We have two AC chargers that have worked fine for many years with many different devices including this current Fairphone 2. On those two chargers, the device now either loses power or just doesn’t charge.

Also, yesterday there were other odd symptoms that suggest there’s more going on than just a battery or charging issue:

  1. First, it kept showing the “charging” symbol even though no charger was attached. After I rebooted, the charging symbol was gone.
  2. Second, same day, I noticed that even though the device had not been attached to any charger, the battery status had suddenly jumped from 10% to 35% or so. Sadly I didn’t make any screenshots.

I’m going to see if I can recharge the device using an AC-to-USB converter in combination with my trusty cable that’s currently allowing the device to recharge from the powerbank.

Also I’m going to check if the device’s socket for the charger has lint or other stuff inside it. That would be my only hardware-ish explanation for the odd “charging symbol while not attached” situation.

EDIT: (Within the minute!)

Just noticed something very odd. A few minutes ago, the device was saying it did not have any power at all. It had turned itself off, the red light was be flashing. NOW however, after it has only been on the powerbank for a few minutes, it says the battery is 30% charged.

I remember now that I’ve had this situation before, once or twice in the last few weeks.

Something tells me this is a software issue or in the most physical-harware-ish scenario an issue with whatever it is that tells the OS the battery charging level.

I would suggest you do a battery reset.

I can add my story of odd charging behaviour, that I discovered only last week.

  • First symptom is power draining or rather drop from 30% to 15 to turning off.
  • Doing a kickstart of the battery, I plugged the phone in and it started charging. I did not start the phone and left it for a few hours but it would not charge to more than half (guessing by the blue battery graphics), while becoming hot just above the battery.
  • Turning the phone on, charging commenced from 54% on to 100% in less than 2.5 hours. The “hot spot” on the back of my phone did cool down.

Battery draining seems to be increasing and a problem that should be really looked into (as I guess they already are doing).

Hello,

I’ve just a huge problem. I’m no longer able to charge my phone without shut down my phone ! It’s no more complicate.
Argggg, what I have to do ? I think I’ll change my phone tomorrow. I cannot continue like that.

I tried with several cable (official HTC cable, cheap cable, …) and several source (from my pc, from an ac power, …). Come on, what wrong with that ! I’ve my phone from more than 1 year !

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.