Barclays Banking app doesn't work

Continuing the discussion from Misbehaving Apps - will be fixed with first update, workaround: re-enable privacy impact:

At first I had this problem with many apps (evernote, mendeley, keepass2android) where I’d press a button (e.g. to log in, open credentials for something else etc) and it would just not work. I found the question linked above and followed the workaround there (privacy impact) and that seems to have solved the issue for most of my apps except for Barclays Mobile Banking. That still doesn’t work. I can’t register. If I enter incorrect details, I get an error saying “incorrect details” as expected. If I enter correct details, when I click verify it just sits there for a while and then returns to the same screen, with no error message or anything instead of progressing to the next page. I’ve been on the phone to barclays mobile banking technical support for an hour to make sure there was nothing wrong on their end, they couldn’t figure it out. Any ideas what it might be?

Did you root you phone? Banking apps normally don’t work on rooted phones…

1 Like

Did you try disabling and reenabling Privacy Impact after you installed this app and started it for the fist time?

Hi, thanks for the quick reply!

Irina, the phone is brand new, just arrived. Not rooted.

Paul, the order of events was:

  1. install the app, try registering and fail
  2. discover the linked forum post, untick disable privacy impact
  3. try registering again and fail
  4. call barclays customer support, uninstall the app, reinstall the app, try registering and fail.

For others with this problem I actually managed to get through the registration now with a rather ugly but fortunate workaround. After each page submission, the app actually saves your progress even though it doesn’t progress onto the next page. So I enter my details on the first page, click continue, wait for it to verify and fall back on the first page. I then quit the app and restart it. This time it starts up on the second page. I enter the required details for second page, submit, wait for it to verify and fall back on second page, quit the app again and restart etc. There are 4 pages of registration if I remember correctly. Once registration is complete the app seems to work fine.

I had also the kind of issue (before rooting my phone) with Bancontact mobile App (a belgian banking app).