Backup in recovery mode (FP1)

When I try ‘backup user data’ from recovery mode, I get to about 1/2 and then it gives an error:

SD card free space: 15185MB
User data allocated: 8389MB
backup file: userdata_20130801_111031.backup
Error: write error
Error: Short write

The phone currently is not bootable, so what do I do?

Previous threads don’t offer a solution.

Could you reformat the SD card (=you will loose all data on it) or try another one? I assume the the file system on the card could have issues.

If above doesn’t work: Which recovery are you using? It could also be that the recovery is buggy. I was never too happy with the default one. It’s possible to replace it, but I’m not sure if you want to take the risk without a proper backup.

1 Like

The SD card is mint, reformatted it anyway, didn’t help.

Using the standard recovery that appears when you hold power and volume up. The link you provided does not help me due to the “On your phone check: System Setting -> Developer options -> Stay awake [x] & USB debugging [x]” requirement since the phone boots into an endless (3 days+) blue “Fai*rphone” startup screen and I therefore cannot change the setting.

Is the card formatted as FAT32? (I don’t remember what the default format is, nor which formats are supported) In that case files larger than ~4GB cannot be written to the card (and 8+GB of userdata will probably lead to a backup file larger than the limit).

The backup gets written as a single file? That could indeed be the problem.
What file system being able to handle files of that size does the recovery
support then?

Unfortunately, I can’t test at the moment (and I’ve never tried a backup from recovery). I’m not even sure about:

  • What the SD-card is formatted as by default
  • Whether it can be changed to another format (and still work with the recovery)
  • Whether the backup is actually a single file, though I strongly suspect it is given it lists a single file as backup file

I’m assuming you have tried this before, but just in case if you haven’t: have you tried getting the phone to boot normally by:

  • wiping the cache from recovery, and then choosing reboot option from the recovery menu?
  • saving a relevant update file to the SD card, and using the apply update from SD card option to install it? (i.e. re-install the update).

Well, I presume there is a built in way to deal with backup files larger
than 4GB? How else would a Fairphone user do a backup using the recovery

The 16GB SD-card I bought came formatted by default. I could try formatting
into various file systems but would strongly have liked a priori
information on how the recovery mode is supposed to deal with >4GB files.

Tried wiping the cache (of course), that did not change anything.

Do you think reinstalling the last update from SD will do the trick?
Doesn’t that result in a situation equivalent to a factory reset as far as
personal data is concerned?

Seeing as the recovery was built by Mediatek, I personally wouldn’t count on it. The default backup app was also written by them, and it really doesn’t do a very thorough job.

There’s actually a similar discussion about recovery backups failing over here, seems ext4 is also a no-go:

It normally shouldn’t affect user data other than perhaps the occasional settings in, for example, google apps. Basically you’d have the same effects you’d experience doing a regular software upgrade. Whilst the instructions I linked to provide an optional step of deleting user data, this can be skipped.

@Valentine79 I think I had the very same problem, see Fairphone does not boot up anymore (bluescreen)

I tried to format my SD card with different file systems but the recovery mode seems to work only with FAT32, that has the 4GB file size limit.
After many tryings, the only thing that worked in my case was resetting the phone, and losing all my data.
I wish you better luck!

Reinstalling from an SD card also did not help, no matter the version, the phone still boots endlessly.

Do you think it might be worth waiting for the now announced android 4.4 release for the FP1 before abandoning and wiping the data? Is the updater a hard coded thing or can it be updated along with the the os? 4.4 might also resolve whatever problem causes the endless boot now…

Thank you for your help nonetheless!

I managed to do a complete (nandroid) backup using CWM recovery. It was compiled by @chrmhoffmann, who also built the unofficial Kitkat for FP1. Find the recovery following this link:

I fear though that if you make a nandroid backup and restore it, you will also restore the errors.

Well, what I want the most is to retrieve the data on my phone. Or is that inaccessible from the backup file?

I’ve never tried that, but there is a feature in the paid version of Titanium Backup, which let’s you extract data from Nandroid backups:

(The third option)

Isn’t a nandroid backup just a tar archive?
It’s a while ago that I opened the last time a CWM backup, but if I remember correctly, I think I simply untared (i.e. extracted) it on my pc.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.