🇫🇷 "Aucun accès internet" affiché mais le navigateur a accès à Internet

Bonjour,

depuis 2 jours, une croix s’affiche sur le wifi indiquant qu’il n’y a pas d’accès internet.

Dans Paramètres/Réseau et Internet, il est indiqué “aucun accès à internet”.

Pourtant le navigateur fonctionne parfaitement et accède à internet !!??

Si je coupe le wifi, la croix bascule sur la connection 4G mobile et idem, seul le navigateur à accès à internet.

Les sms/mms fonctionnent aussi.

Le seul problème pour moi c’est que Davx5 m’empêche de synchroniser mon calendrier et mes contacts car lui se plaint de l’absence d’internet.

Serait-ce un problème d’opérateur (Sosh) ? Je soupçonne que uniquement l’url ou le serveur qui permet de vérifier la connexion internet ne fonctionne plus (problème dns ou autre).

Une idée ?

Bonjour et bienvenue sur le forum de la communauté :slightly_smiling_face:

Est-ce que vous utilisez un VPN?

Sosh étant une branche d’Orange, et le problème tout récent, je pense qu’il faut commencer par poser la question à votre opérateur.

Merci pour la bienvenue !

Non.

Pour l’opérateur, j’en ai deux, en wifi je suis sur l’opérateur internet qui n’est pas Orange et en données mobiles je suis sur Sosh (Orange).

Donc finalement, à bien y réfléchir, ce n’est pas un problème d’opérateur.

Plutôt un problème de la façon dont le Fairphone détecte si une connexion internet est disponible.

J’ai éteins le téléphone, retiré la batterie et la carte sim, puis remis le tout et redémarré, sans succès…

Bon ben on repart sur les bases :

  • quel n° de build ? - J’ai rĂ©cemment vu des problèmes similaires qui ont Ă©tĂ© rĂ©solus par une mise Ă  jour de l’OS.
    (Paramètres > A propos du téléphone > Numéro de build)
  • auriez-vous modifiĂ© les permissions de quelque chose ces derniers temps ?
  • c’est peut-ĂŞtre un problème de DNS.

Voici mon build, OS de base /e/ :

e_FP3-userdebug 9 PQ3A.190801.002
eng.root.20220406.155646
dev-keys,stable-release

  • Je n’ai pas modifiĂ© de permissions.

  • Seule nouveautĂ© avant la panne, j’utilise une application qui fait du wifi direct (insta360 app), aurait-elle modifiĂ© des paramètres wifi ? Mais alors pourquoi en 4g j’ai aussi le problème…

  • J’y ai pensĂ© car le dns de mon opĂ©rateur internet (wifi) est parfois en panne, mais cela ne dure pas plus de 3mn. Le dns mobile de sosh a toujours fonctionnĂ©. Les dns Ă©tant diffĂ©rents entre mes deux opĂ©rateurs wifi et mobile, j’ai tendance Ă  Ă©carter cette hypothèse.

Juste une idée comme ça: Votre problème ressemble beaucoup à un problème de proxy: C’est à dire que votre téléphone utilise à present un proxy qui ne fonctionne pas, mais comme les navigateurs ont leurs propres paramètres proxy, ils contournent le mauvais paramétrage du système. Ceci expliquerait l’apparente contradiction.

Quant à où se trouve le paramétrage proxy d’Android, désolé, il faut attendre que quelqu’un de plus au courant se présente…

Vous n’auriez pas installé une sorte de firewall, un bloqueur de pubs, ou une autre application de ce genre? Sur Android, vu que les applications installés par l’utilisateur tournent en tant qu’utilisateur non privilégié, la seule façon d’intercepter et filtrer le traffic est de déclarer l’application en question comme proxy internet. Ca pourrait être la raison de vos déboires.

1 Like

Voilà, donc vous êtes sur /e/ avec une version qui date de deux ans, parce que les mises à jour automatiques n’ont pas fonctionné depuis un moment.

De nombreux autres utilisateurs sous /e/ ont rencontré ce problème. Je vous conseille de lire ce topic dans le forum dédié aux utilisateurs du ROM /e/ et voir également ici et ici.

2 Likes

Un immense merci Ă  tous ! :+1:

Le problème est en effet expliqué et des solutions proposées sur le forum de /e/ OS.

  • J’ai installĂ© l’application Captive Portal Controller via f-droid.
  • Puis autorisĂ© son utilisation via adb.
  • Dans Captive Portal Controller, j’ai choisi une url de vĂ©rification de portail proposĂ©e et activĂ© son utilisation.
  • J’ai ensuite Ă©teins et relancĂ© le Wifi et les croix ont disparu, mĂŞme sur les donnĂ©es mobiles, mon calendrier s’est resynchronisĂ©, les mises Ă  jours d’application se sont lancĂ©es, etc.

Problème résolu ! :partying_face:

2 Likes

J’ai installé Captive Portal Controler.
Maintenant je ne sais pas autoriser son utilisation via adb ???
Est-ce qu’il faut installer ADB Manager par exemple ou autre ?
Merci