Apps not working properly on Fairphone 3


So, I don’t know what it is but some Apps just behave in a very unpredictable manner but all worked perfectly fine on my old Motorola G5.

I keep getting logged out of apps like
Telegram and Too Good To Go.
I always have to set them up as if they were newly installed when opening them.

Then there’s Nova Launcher.
An app that allows me to further customize the homescreen. It works mostly fine but it deletes certain app icons from the homescreen for no apparent reason.

I also use Tachiyomi, an App that’s a bit of a grey area, not downloadable from the playstore, but it always worked fine on my old phone. My Fairphone 3 though completely freaks out when I open it. It leads to a loop of opening and closing a white screen.

I checked each individual settings, deleted caches, force closed and reinstalled them and so on. I even resetted the entire system. Nothing.

What the hell is going on?
If a phone that was nearly 10 years old worked more properly than this new one, then I kinda feel immensely disappointed if not cheated.

Hi and welcome to the forum

A couple of things to try

  • Start in Safe mode, his disables any custom apps to ensure the basic OS is fine
  • Secondly check the SD card > Ensure it is formatted as Portable
  • Check the amount of ,memory you have . Of the base 64Gb try and get 10Gb free, so clear the cache of at least all the apps you are having a problem with.

Note if you use an SD card as Internal all the content is encrypted, so if you have any personal data, images etc. and the phone fails at some point, which it will, then you will loose all that data, or in other words you will not be able to retrieve it with enormous cost.

1 Like

Hi was it a combination of things or did you isolate a particular thing that was the issue

That was it! The apps that didn’t function properly were stored on my SD card.
Now they work fine after relocating them.

One thing I shoukd mention in case anybody reads this with similiar problems.
After converting my SD Card, it didn’t get recognized. Re-inserting it seemed to do the trick.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.