Apps disappearing from homescreen after update to 1.8 (internal storage and partition upgrade)

Hi there,

have had the 1.8 update for a few months now and since then these problems.
Always hoped that they are gonna be solved soon, but since nothing has happened yet I’ll try my luck here:

Every few days my phone just reboots on its own. There is nothing that activates this reboot, neither time/date or a specific action - it happens randomly.
Problems that occur:

  • I have to enter my PIN again
  • I’m logged out of nearly all my connected accounts (Twitter, Facebook, Tumblr, …)
  • The “Your apps” (recently used, most used) has been reset
  • Only half of my home-screen is the same as it has been before, the rest of the apps are not displayed anymore (see 1st screenshot)
  • When I try to open one of the empty app folders it says “‘Fairphone OS v2’ wurde beendet” (see 2nd screenshot)

The same thing happens when I manually restart my phone or the battery dies.

Have these problems been already reported elsewhere? Can I fix them somehow? And when will the new update be released?

Thanks a lot

Hi @weheri!

What have you done to solve your issue? Have you e.g. clearing the cache of Fairphone OS v2 (=the default launcher)?

A search around the forum might also help you, it’s the little magnifying glass in the upper right corner of the forum. :smile:

Hi @Stefan,

thanks for your answer - unfortunately it didn’t help… Cleared the cache, rebooted it and rearranged the homescreen again. Today it shut down again (didn’t even restart) and most apps aren’t on the homscreen anymore, logged out of nearly all accounts.

One thing I’ve found out: All apps that disappear after a reboot are not stored in the internal memory, but the phone storage. Apps stored in the internal memory are not affected and I’m not logged out of these apps.
But I don’t have enough internal memory to store all my apps there and it still doesn’t solve the problem with the random reboots :confused:

1 Like

Okay, just found out that there’s a “storage upgrade” that can only be done in 1.6, will try that out tomorrow and report :slight_smile:


Okay, this seems to be working.

After reinstalling all apps I just tried a reboot - my accounts didn’t log out and all apps stayed in place!
But now I have some other issues with getting all my backups back onto my phone :confused:

1 Like

Great you got this working! :slight_smile: And thank you for opening a new thread because of the different issues!

This topic is now closed. New replies are no longer allowed.