APN setup problems abroad

Hey everyone,

First of all, thanks for the opportunity to ask questions here. I’m new and a few old threads have already been very helpful.
Basically, I have the same problem as user Trust in this link [SOLVED] APN disappears when changing MNC

with a slight modification:

I have a contract with PremiumSim which uses the network of 1und1. Everything has worked fine so far.
I’m living in Portugal this summer and have now received a new SIM card from PremiumSim (since they are switching to 5G) and the old one has been deactivated by 1und1.

The only APNs shown are Orange World and Orange Enterprises.
According to 1und1, I should set up my APN as follows:
Name: PremiumSIM
APN: internet
APN type: default
Proxy: Not set
Port: not set
Username: Not set
Password: Not set
Server: Not set
MMSC: https://1und1-mobilfunk.de
MMS proxy: Not set
MMS port: Not set
MCC: 262
MNC: 23
Authentication type: do not define (same as “Not set”?)
APN protocol: IPv4/IPv6
APN roaming protocol: IPv4/IPv6
APN enable/disable: APN enabled (tick)
Bearer: Unspecified

However, the problem now is the same as with user Trust, that the newly created APN disappears when I enter MCC and MNC for 1und1 Germany. I click save and it simply does not appear anymore. With the preset MCC and MNC (208 and 02 for Orange France, who knows why) it works, but then I have no internet.

User “Johannes” had said: “Forgot to mention - the reason the APN disappears is because it only shows APN settings that are relevant to the current network the sim is connected to. As it seems to be connected to MNC 07, changing the setting to MNC 02 makes the system ignore APN as irrelevant to the current connection. You’d need to force a connection to the other network using manual network selection (different options menu altogether) - but as stated above, in this case I believe you’re on the right network and the 2G/3G/4G toggles are your actual problem.”
I have now tried various combinations of MNC and MCC.

The only two networks I can manually select here are Vodafone and MEO and with both the APNs provided by the provider disappear as well.

Do I now have to travel to Germany to create the APNs in the network there and only then can I select them? I hope not…

It would be great if someone could help me. :slight_smile:

Best regards,
Flo

So 1&1 has their own network in the meantime? Have a look here as well, reg the ipv setting and maybe try to switch to 2g only

Would that be a question for the provider? Maybe its easier to get a Second Portuguese SIM for the time you are in Portugal?

Hi Flo and welcome to the community forum :slightly_smiling_face:

Changing SIM whilst roaming is indeed likely to complicate things. Did you check your subscription details (presumably on the PremiumSIM website) that roaming is still enabled?

In Settings > Network and Internet > SIMs > [your SIM] , is “Roaming” enabled? This is for accessing mobile data (i.e. Internet and stuff) while roaming.

For the APN settings:

  • Authentication type : if not defined, put “None”
  • APN roaming protocol : try using just IPv4
  • Are there no values for the MVNO type and value?

How long are you staying in Portugal? You might get a local SIM for the duration of your stay, though that would be a last resort. [I see that yvmuell has replied in the mean time and suggests the same. If you want to use both SIMs then the second would have to be an eSIM.]

1 Like

Hi Flo, I have the exact same problem! My sim.de APN is working perfect in Germany but once I go to Bulgaria (my home country), I can only see the Orange APN’s and can’t remove or edit them. The sim.de support is also not able to help me. Did you by any chance find a solution?

Hey Mitodo,

unfortunately I haven’t. The premiumsim tech supp did everything with me, reseting every possible thing.
But interesting, so it works for you in Germany but when you leave it not anymore? Since I put the SIM in here in Portugal, I thought it just needs to connect one time to the german network and then it’s saved, so I wanted to send my phone back home to a friend, he is setting up the correct APN for the 1und1 network and I thought then it’s saved and if he sends me my phone back I can use it… but when you say it’s not working anymore when you leave Germany? Then it might not be the case as well…

I had contact with the Fairphone Support and they wanted to reach out to me again these days. I’ll inform in this thread here as soon as they are giving me any information!

I even tried the vodafone network which is available here and works for my phone and tried to use vodafone APNs for portugal (it’s the same network so it should work), but no matter what I do, the only APN I can choose is the orange world or orange enterprese.
This one actually worked (orange world, it worked bad and just from time to time), but now I’ve reached 10GB and it stopped completely since a week. in my PremiumSim Account, there’s written I have used 0MB of my mobile data since a month (the day I put the new SIM in), so I have no idea where those 10GB went. Everything here is so god damn confusing the deeper I get into it. :smiley:

I actually dont want a portugese SIM, since I have tons of stuff connected to my original number…

The portugues SIM or. a travel SIM is only for mobile data, the rest will not vanish when you insert a second SIM to have mobile data? No contacts no Whatsapp no mails.,.I was in Canada and for sure did not want to use mobile data from my German SIM so added a travel SIM and could just use my phone when I had no Wifi connection.

And @mitodo86 experience clearly is not “normal”.

Edit: I’m still wondering if this is connected somehow to the not very useful 1&1 network? Its new and not very wide spread so maybe the world cant handle this? Also I know that 1&1 support lets say it nicely isnt the best…

@mitodo86 do you know which APN you use while in Germany?

Both: as the 1&1 network is not wide spread does your account use Telefonica when not covered, so maybe try the O2 APN?

It seems SIM de changes to Vodafone did this just happen while you traveled @mitodo86 and therefore there is no APN?

I found a solution:

A new APN has to be created with name: O2 Internet and APN: Internet, no other data is needed! After saving it and selecting it as default you should have Internet.

Hope it helps!

1 Like