Android - something messed with several app

Hi @all, I have a Feirphone 4 with Android 13, which recently installed some updates ( I think). Since then I can not use the phone properly anymore and I have troubles figuring out what to do. So I can not open WhatsApp, the Camera, Signal, Maps and many other apps.
I tried

  • deleting and reinstalling the apps - did not work
  • deinstalling lates updates - did not work
  • install updates - did not work
  • resetting the app - did not work
  • empty cache of several apps including playstore and restart - did not work

I would really like to avoid reinstalling the OS. Did anyone experience similar issues and if so how were they fixed?

My OS details are:

  • Android 13
  • Kernel Version 4.19.157
  • last Android Security update: 05.05.24
  • last google play system update: 01.05.2024

I have been facing problems since yesterday.
I have no clue which updates were installed yesterday, since I was biking when my phone suddenly restarted.

I appreciate any help or advice.

Hi and welcome to the forum. Sounds like you have an SD card inserted which is formatted as internal extension?

3 Likes

I removed it and it magically worked. I put it into the computer, and the SD card seems broken. I would have never thought this would cause my apps not to work anymore.
Thank you a lot!!! This was super helpful :slight_smile:

1 Like

glad it helped. Just one comment: if it is formatted in the phone as internal extension and not portable, you would never be able to access the data on it with any other device. Maybe you want to read sdcardguide

1 Like