Android KitKat (4.4.4) for FP1

Just wanted to mention:

  • IMEIs did not get lost at any time during my upgrade - downgrade - upgrade mess
  • Media playing works just fine (VLC)
  • Very nice: Voice messages sent with Signal to an iPhone that were completely garbled with the official 4.2.2 OS sound perfect now
  • Since the last freeze with battery removal the phone is stable so far
  • I found my old ringtone back

I’m very happy the old FP1 is now usable without limitations again! :+1: :slight_smile:

1 Like

Another thing I’d like to mention is that I think restoring certain settings with Titanium Backup caused quite some trouble as part of the upgrade:

  • Restoring phone settings seemed to either make the phone function and SMS/MMS disappear or crash in an infinite loop
  • Restoring some system settings (unfortunately not sure which one) put the phone in a state where it was not possible to install most apps, regardless how (Play Store, F-Droid, Titanium Backup, local APK, …) with the error that there is not enough space/insufficient storage. Only restoring apps + data does not cause the issue.

And, when trying to add this widget to a screen, it crashes with the following exception:

I/ActivityManager(  688): [AppLaunch] Displayed Displayed +105ms (total +31m12s910ms)
D/ActivityManager(  688):
E/ActivityManager(  688): mtprof entry can not found!
E/ActivityManager(  688): /proc/mtprof/status: open failed: ENOENT (No such file or directory)
E/ActivityManager(  688):       at
E/ActivityManager(  688):       at<init>(
E/ActivityManager(  688):       at<init>(
E/ActivityManager(  688):       at
E/ActivityManager(  688):       at
E/ActivityManager(  688):       at
E/ActivityManager(  688):       at$Token.windowsDrawn(
E/ActivityManager(  688):       at$H.handleMessage(
E/ActivityManager(  688):       at android.os.Handler.dispatchMessage(
E/ActivityManager(  688):       at android.os.Looper.loop(
E/ActivityManager(  688):       at
E/ActivityManager(  688): Caused by: open failed: ENOENT (No such file or directory)
E/ActivityManager(  688):       at Method)
E/ActivityManager(  688):       at
E/ActivityManager(  688):       at
E/ActivityManager(  688):       ... 10 more

Probably because the Mediatek mtprof driver is missing?

Did un upgrade from unified 4.2.2.
Had to wipe cache and data.
Experience an odd behavior:

  • the device can last as long as needed in recovery,
  • the device reboots within the 1st minute of normal usage.

So the usability gets limited.
I tried both z3ntu images 0.0.2 and 0.0.3-pre5.
Any idea what it could be ?

Did you update to 0.0.3-pre5 “on top” of 0.0.2 (i.e. you did not go back to 4.2.2. in between)? If yes, then maybe I’d try another “clean install” instead.

If you do so, I would appreciate if you could test my observation about the (in)effectiveness of the CWM recovery wipe. :angel:

I did find back in 4.4.4 a photo made with 4.2.2 (already at the 1st attempt).
But as it did not boot as long as I did not wipe the data, your observation is verified.
(for the record I 1st tried to wipe the cache, and then the data and I verified the md5sum of the download 0.0.2 and 0.0.3-pre5).

Then, I confirm that using 4.2.2 (1.8.7) on the my suspicious unit is working for many minutes without reboots.

Back on 0.0.3-pre it’s rebooting again after around a minute of usage.

I tried CWM format option for /data and /cache, with an effective loss of settings , but no improvement in the wake-up time.

1 Like

I installed 0.0.3-pre5 last night and I still get the Error message "SSL handshake aborted" in an app:sob: What could be the issue?

GPS doesn’t work here. SatStat shows 0/0 satellites and TTFF (s) 0. It doesn’t even seem to be searching for satellites… :confused: I use Unified NLP and network location is fine.

Before the upgrade GPS was working fine (I was able to use it a week before upgrading). How can I find the issue?

Edit: GPS works fine. It just takes ages for the fix, as usual.

Got a bit silent in here…

@z3ntu: Are you still developing? No grouching, just asking!

I did some testing and ran into a problem getting tor to work (orbot app). Neither the recent version nor the older (15) build will connect properly, worked seamless on stock.
Probably me stupid, but might point to some problem.

Furthermore I also tested GPS (with Osmand) and found it working alright. It took less than 15 min to first fix.

1 Like

I should do a 0.0.3 version sometime soon… I’ve actually started working on a tool last month to backport the national roaming configs (as mentioned at Android KitKat (4.4.4) for FP1): , but it still needs some work.


Thanks @z3ntu for ROM 4.4.4, it’s wonderful to have the Fairphone updated! :slight_smile:

Thanks @urs_lesse for the tutorial :slight_smile:

Version 0.0.2 works perfect for me.

I had problems with version 0.0.3-pre5 when playing mp3 (with Pulsar, Vanilla, and other sound APPs), and when making Signal voice calls, the APP crashes. But version 0.0.2 works perfect.

In case it helps someone, I could not do tethering and I solved it by installing an APK I found in this forum: (It needs BusyBox installed)

I have also noticed that the remaining battery life indicator gets stuck and gives problems when I turn on the FP1 after being off for a long time (with both 0.0.2 and 0.0.3-pre5). The solution is that the FP1 is always on (turn it off a short time or never turn it off)

Thank you again.


Although version 0.0.2 works fine for me (good to see such a recent security patch on my old FP1!) I would like to know if work on a next version/security-updates continues.

1 Like

It would be nice if you could test the 0.0.3 pre-release version, as the media security patches contained there are planned to be released as part of 0.0.3.

1 Like

Could you send me the mp3 which doesn’t work? From my limited testing I didn’t find any problems.
Could you give me the logcat output when these crashes happen? Thanks.

Can I update from 0.0.2 to 0.0.3 pre-release without loosing userdate?
Anyway: any testing I can do will only be limited; the FP1 is now my secondary phone with only a few apps installed.

Yes, you can update from 0.0.2 to 0.0.3 pre-release without loosing userdate (but you will have to reinstall Open GApps if you want Google Play Store and Google Play Services)

1 Like

Ok… I have reinstalled version 0.0.3-pre5 of the ROM for testing

The error is easy to reproduce when switching from one playing song to another in VANILLA APP. It does not always happen, but many times (It doesn’t happen only with a specific mp3, but with anyone, randomly).

Errors playing mp3 never occur with version 0.0.2 of the ROM.

Signal APP crashes or makes errors when making the second voice call, the first call works OK.

I have sent you a private message with the logcat (filtering errors)

1 Like

Done: no issues discovered (with the limited number of applications I use).
Keep up the good work!


Well, if I want to keep using my FP1U, I think I need to upgrade to this version… :roll_eyes: Not something I like to do…

Hallo everybody,
I’m very glad, that I found this possibility to bring my fp1u into a second life - and that there are great people, who spend their time on it! Thanks a lot!
The mentioned basketbuild-link to the recovery.img seems broken. Where else can I find that img to try it out?


Welcome @HvConta !

I found the recovery.img file on my PC and uploaded it to this link:

1 Like