Android Auto not connecting anymore

Since the last update FP4.SP28.B.065.20230420 my Fairphone 4 does not connect anymore to Android Auto in my car. I get the message to try with another cable. I tried several to no avail. Rebooted my phone, reinstalled Android Auto on the phone, reinitialised the car’s software, … No change. Tried with my old phone, a Samsung Galaxy S9 and it worked with no issue. So I figure it’s the Fairphone and or the latest software update.
Anyone has an idea or solution to solve the issue?

This could be related to this problem:

In my case I still can connect to my car but not to my hearing-aids.

Bluetooth connection for the phone is still working. The issues is with the Android Auto connection via USB to access apps like Waze, Maps, …

Ok. Then that´s a different problem.
But I can’t help with this, since I’m only using audio streaming and not app sharing.

Hi and welcome to the forum.

I don’t have a car, but I guess there are a couple of things to check after you connect the USB cable,

  1. Just to be sure, check appropriate connection mode?
    Settings > Connected devices > USB
    and then choose File transfer (I presume …)
  2. Settings > Connected devices > Connection preferences > Android Auto
    and review the multifarious settings.

In particular, in “Previously connected cars”, you might want to forget them and connect afresh. See also “Connection help”. You might need to turn off USB debugging if it’s on at the moment.

Android help:

1 Like

Hi and thanks for the detailed advice.

I had looked at all the items you mentioned.

  • The usb transfer option ( file transfer or charge) doesn’t show up when you connect to the car.
  • I checked the Android Auto option and deleted the old connection.

Thanks again

Did you look in these?

For example this one.

Some people found that clearing app data and cache on the phone helped.
Settings > Apps > See all apps > Android Auto > Storage and cache > Clear storage, then Clear cache.

1 Like

Thanks again for following up.
Cleared the storage and cache and tried any of the mentioned proposals. All to no avail.
Really odd issue. Have had the phone for a year and it had been working really well.

Well in any case it’s important to #contactsupport : do so if you haven’t yet. Of course, make sure they understand that the problem materialised with the April update, and please post back and keep us up to date!


Thanks again for your help. I’ve just contacted customer support and will keep you posted.
Best regards

Hi, I have the same issue - did you get a solution via customer support?

I was in touch with the Fairphone support and the person was very helpful. However, non of the proposed actions solved the issue. I’m now asked to send the phone in for repair. I cannot do this because it will leave me without a phone. I will try as a last resort to do a factory reset to see if this solves the issue. Several additional informations: when I connect the phone to a computer, it will not show the option to use the usb port for charging only or for data transfer. It will only charge. The phone will not connect. I can, however, connect a śsd drive or a SD card to the phone. They will mount. This means that the usb port can function and it is not a hardware issue. Using a cable with two usb C connectors at both ends also works for connecting to a computer.
Once I have done the factory reset I will post the outcome and also all the correspondence I had with Fairphone support.

1 Like

So to recapitulate the facts:

  • USB connection not working since update FP4.SP28.B.065.20230420
  • Other phone works (so probably not a problem with the car’s USB port). Is that using the same cable as the one you’re using with the FP4? I suspect not as probably USB micro-B?
  • USB C - to - C data connection to a computer is OK. That would presumably exclude the phone itself and the port.

That would be consistent with a cable problem, if you’re using the same cable as in the car. Or a problem with the computer’s USB A port. Try a different cable and a different port or computer.

That’s consistent with the above (cable or computer port).

I don’t think I’ve seen any reasoning that would exclude the cable you’re using in the car. The fact that the problem started after an update may be a coincidence.

Also make sure all cable connectors and ports are clean (vacuum cleaner with narrow aperture tool, plastic or fine wooden toothpick, be very careful).

Thanks JoKa91400 for the update. I did play around more with my phone and seem to have fixed it from my side.

I am not sure what did the trick but I cleared the phone’s Android Auto app storage/cache (that did not do anything), then in the phone’s Android Auto app I set “Start Android Auto automatically” to “Always” (it was on “Default (set by the car)”) + in the car’s Android Auto settings I removed the phone from known devices + in the car’s general app settings I disabled and then re-enabled “connect to applications via USB”. When I tried connecting again, it worked.

(My phone is a FP3 so maybe different issue… The message I got on my phone when trying to connect is “SmartDeviceLink Core Component USB - No installed apps work with this USB accessory”. Didn’t think it was the cable because my family members use the same cable with their phones (which are Samsung S22 and S20), and for them it works fine + it’s the same cable that also used to work with my FP3 in the past.)

1 Like

Hi and thanks for the suggestions.
The other phone which works uses the same USB C cable (Samsung Galaxy S9) so it is not a cable issue. I had also tried other cables to be sure. So the cable can be excluded
I cleaned the USB connector contacts and also opened the phone to take out the USB connector board and clean it (not that it was dirty).
I’ll post all the other action proposed by the Fairphone support. But first I want to do a factory reset to see if that changes anything since I still believe it is a software issue.
Best regards

OK so the cable is out too.

A “factory reset” removes all user-added apps and settings. However it’s not a means to revert the phone to a previous version of the OS, despite the term “factory”. In the present case, I don’t see that it’s going to change anything more than clearing the AA data and cache, but of course that’s just my opinion.

You might check whether an update is available for the AA app.

apahaut’s experience sounds promising (and less painful than a factory reset).

1 Like

I have a similar problem. Other phones connect via USB cable with no problem. However, there is no reaction after connecting to the FairPhone 4…

I would also try to clean storage and cache of Android Auto first (as @OldRoutard mentioned) to see if this helps. Maybe also try to re-pair the BT connection additionally and also try to completely re-install Android Auto.

Thanks for the advice.
I’ve tried another cable (USB 3 to USB C), a very short one and with this I can connect to my computer if I use a direct USB port on the computer. Via a hub it will not work (before it did) and on the car, using the short cable it doesn’t work either.
I also tried connecting to a windows computer (I normally use Linux) where I get the message that the the USB connection is not recognized.
I cross checked everything with the Samsung S9 and all the computer/cable combinations work.
So now I’ve ordered a new USB -C connector board for the phone (14.95€) since it could be after all a hardware problem.
Will keep you posted

Thanks Lars, I’ve tried all of that already. Does not change anything