Android Auto FF3

Hi All,

I’m having massive issues with my Fairphone3 using Android Auto. Before I had a Samsung S9 using Android Auto with my Mercedes E. It never causes issues. Now I’m using the same on my Fairphone3. I always have to connect it 2 times before it will start. The first try always says: cannot be started on my Car Screen, 2nd try is working. Earlier or later it’s crashing completely and I have to unplug and plug my Phone. So I’m lost about the issues…

I installed all latest updates, Os wise but also playstore wise. No energy saving is active or anything else. So normally it should work. It’s working with other phones and also car play is working fine on my business Iphone.

Is maybe the Fairphone 3 not able to run Android Auto mirroring to a screen due to lower hardware? Or is there any strict energy management in place killing apps in background like on the low budget android phones or what can be the issue?

I really love this mirroring feature via Cable but I can’t see any issue as it is working with other devices perfectly. Therefore I assume that something is internally blockig that in the fairphone software or that the hardware cannot do that.

For any help I or experiences I would be thankful.


Hi there and welcome to the community!

  • Did you try another cable?
  • Did you try deinstalling and reinstalling the app?

Did you notice other problems with your phone?
As a last resort, you could try a #dic:factorydatareset :man_shrugging: (:warning: #dic:backup before!)

Pointing this out, although it’s not really related: Android Auto not supported on FP3?!

I recategorized your topic in #help:fp3 instead of #discuss. You can change it again if you want, but this is a better category for your topic as you are seeking help.

1 Like

Dear alex21,

thanks for your message, appreciated. I tried over time several things:

  • cleared cache and data from AA app

  • reinstalled AA app

  • deleted binding with car and re-paired, reseted as well car system

  • re-configured the whole Fairphone + reinstalled all apps

  • cable is the same working for my reference device Samsung S9 but i also tried another data / power cable

  • as well I tried the developer functions: changed the power management for AA app to flag ACTIVE and changed as well the standard USB mode to DEBUG

Nothing of the mentioned things above changed anything. I still need 2 tries to start AA. and it’s crashing randomly after a few minutes whilst driving.

The last bullet point made a small change: I was able to drive with AA for 15 minutes but, guess what, chrashed!

S9 is working fine without any troubles or any issues… I do not get it. I asked around and a friend of mine also having a Smartphone with the same processor as FP3 but not issues… so hardware can’t be the limiter.

I guess, that something is either wrongly coded in the OS adoptions by Fairphone or a hard coded powermanagement is killing AA app after the screen goes off… I do not have any other explanation to be honest. I could give it a last try to not turn off the screen whilst driving but I really do not want it to be honest.

I’m lost with any further ideas…

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.