Android Auto does not work with my brandnew FP5

I had a feeling that the cable might be the problem. Wondering if I should order the €20 or €35 version from the FP shop. Guess the latter will transfer data much faster at USB 3.2 rates but it’s a bit pricey for a cable.

I have try with 3 differents cable and high quality ones.
It’s not that unfortunately

Well what is happening is :
Nothing happen except charging the battery.
It doesn’t connect to my car screen
And when I try to add a car through the app, when they ask to plug the cable, I do it and nothing happen except charging the phone.

It works fine on my FP5, as it did on my FP3 before (Renault Mégane). Is your Bluetooth connected? I’m not sure that’s a prerequisite, just that mine is always connected.

Well it’s supposed to be connected with cable usb C
Bluetooth doesn’t offer ggmap Waze etc…

I know :wink: just saying, I have both on. Never tried to do my first connection to Android Auto without BT on/connected.

What brand car do you have?

Suzuki Baleno Hybrid 2016

That car’s not in the compatibility list (scroll down to suzuki). Have you ever tried another Android phone and confirmed it’s not the car that doesn’t support Android Auto?
Android Auto Compatibility | Android

Android Auto is compatible with the following vehicles.

  • May require software update.

  • Hustler 2016- *

  • Ignis 2016- *

  • Lapin 2016- *

  • Solio 2016- *

  • Solio Bandit 2016- *

  • Spacia 2016- *

  • Spacia Custom 2016- *

  • Spacia Custom Z 2016- *

  • Swift 2016-

  • Wagon R 2016-

  • Wagon R Stingray 2016-

(unless it’s also known under another name?)

1 Like

according to Suzuki website Baleno from 2015-> is ok

ok. Strange then, that it doesn’t work for you. Have you tried with another Android phone? Have you contacted your dealer? (maybe a software update’s needed in order to enable Android Auto)

Hi B_Roz,
I had some issues with the connection between my Suzuki Swift 2018 and my previous phone (Samsung A50).
Unfortunately I never tried to connect my FP5 (which has e/OS/ btw), so I cannot help you regarding the phone itself. In the past, when I was facing the same problem with my android phone, I had to start the engine and keep the handbrake on, until the android auto app correctly connected.
This worked sometimes and sometimes it didn’t, so it became so frustrating I gave up.

I’m not sure if it required the engine to be completely on or just the electric contact to be on, but I’m certain about the handbrake.

Hope this could help!

Problem is I am stuck here.
Nothing happen when I plug in

It would help a lot of you could find another another Android phone and check whether it has the same issue. And if it doesn’t work either, do yourself a favor and ask your Suzuki dealer if there’s a software update you’re missing.


I think the wired Android Auto and even CarPlay require Bluetooth connection for sound. The USB bandwidth is not big enough to fit everything (video, audio, metadata). I assume it’s an old USB 1.0 standard (my car has a white USB socket for Android Auto).

My FP5 works without issues in my car (different brand), and I even tried it with various Android Auto wireless adapters. All good. The same was true with FP4. Since FP5 uses an almost stock Android, it should be fine out of the box unless you change settings.

The first thing I would check is the cable. It has to support data transfer. I would try to confirm that by:

  • setting the phone in MTP/USB Storage mode
  • connect it to a computer or even to the car in storage mode to check if it detects audio files on it (assuming your car supports it, and you have some music on the phone).

A lot of cables are “charge-only” cables. They don’t have the wires for the data lines. My father had the same issue. Because of this, he took his car to warranty, and he was a bit embarrassed when the outcome was a note: buy a “data” cable.

Then I would double-check this:

Then, play with different USB settings by searching for USB in the configuration app.


I have recently acquired a Suzuki Swace, which features Android Auto and is not featured on any of the compatibility lists posted earlier in this thread. When I got it, I was very eager to try out Android Auto and was immediately disappointed when it just didn’t work with my Fairphone 4 on Android 13.

Luckily I had multiple cables at my disposal which I could try out. Only one would work: The one with a blue USB A to C connection, meaning a USB 3 cable. All the others, which had white USB A plugs did not work as I guess speed is not high enough or they are just charging cables.

When I asked the dealer as to why Android Auto needs a cable at all he responded that there is simply too much data being transferred and only very recently (I guess via Bluetooth 5 or Wi-Fi) is it possible to use Android Auto wirelessly.

So all this leads me to believe that Android Auto needs a good USB 3 compatible cable to ensure it has the proper bandwidth available.

1 Like

Which software version is running in your cars navigation system? Did any other Android ever run on this car? My Opel needed an update first, when i got the car because no other Android device at all connected (some years ago).

In case of Android Auto problems please always try to cross check with other Android phones (e.g. colleagues) and cables. Please check car manufacturer related topics in other support forums as well.

Please note, i googled your car type and there were reports of other users with other phones that had troubles with some firmware of the car …

My FP5 connects out of the box via wired Android Auto without any problems with a Toyota C-HR and an Kia EV6.

Even with an AAWireless-adapter I can use wireless Android Auto with my FP5. This works with all three firmware versions I used on my FP5 since I bought it.

Thanks to all of you
I will buy a generation 2.1 blue usb C short cable to try (already try with 3 diff cables)

I can’t access to update option in my screen car, was working with iPhones but not with android, I will see if I can do update in a Suzuki garage.

A post was split to a new topic: FP4 Android Auto not working

I got the more expensive USB 3.2 cable, and so far Android Auto now works. There has been an occasion where it didn’t, but this was probably the fault of the car’s system as it worked before in this same car and it works without issues in another car.