Android 10 - MicroSD as phone storage

In case you do not know this, I never used, but have seen comments here, that it helped

That using internal storage is often a bad idea, is def nothing only related/known to/since the FP3. Things with Google and Android are not always that easy as one might think and companies have to go through thousands of approvals before rolling out customizations. So even of I agree that it would be best to just remove this option, it might be Google to blame and not Fairphone

It’s been going on since Android 6 . It was happening in FP2 days etc.
Fairphone. I’m not sure there is a fix but a warning may be useful that’s if people read all the instructions manual etc, which of course do not come with the phone.

As far as recovering more info may be usefull.

Did you have photos on the phone before inserting the SD card?
Did the camera continue to save or stop?
Have you removed the SD card and done anything to it i.e. try to reformat it etc.
Is the card back in the phone.

OK Have you tried using adb to access the phones memory to see what you can find?

Although I use a Raspberry Pi here is some idea of how adb can be installed and used.

I can fully understand your frustration and I agree with you. Unfortunately, I will have to quote myself:

Fairphone do not consider this as a bug, as they can’t reproduce it. Therefore, it won’t be fixed as long as they can’t hold relevant information. Please contact them directly, all we can do as a community is advising you not to format it as internal storage, and asking Fairphone to remove the option (which wasn’t done).

This community forum is not an official support channel. Therefore, even if this topic is one year old, it can’t be hold against Fairphone for not fixing the bug for reasons explained above. This is sad and unnnerving, unfortunately the only thing we can do here is complaining to Fairphone and providing useful information for fixing it.


Hello all,

unfortunately I’ve experienced similar problems as people who wrote in that thread before me. After more than one and a half years of using my FP3 I’ve added a SD card (SanDisk Extreme 32 GB microSD) and formatted it as internal storage and moved apps and data as well. First everything seemed fine. Around 20 GB of data was moved to the SD card which I could see in the settings. But then my camera app wouldn’t let me take pictures and I also could not open old pictures anymore. After a reboot all my pictures were gone and the storage of the SD was much emptier than before. The phone also asks to put in the SD card though in the settings it appears. When connecting the phone to a computer I just can find the sd card and don’t have access to the storage of the phone itself.

I am still desperately hoping to find a solution to recover my pictures and data and to fix that problem without having to reinstall everything. So if anyone has a good advice I would be very grateful. Has anyone tried the PhotoRec application yet?

I’ve read the whole thread and thanks for all the good suggestions. Hopefully anything is working for me.

1 Like

Hi and welocome to the forum.

Sadly the SD once formatted as internal can only be read from the phone as it is encrypted.

You can connect via adb but I haven’t tried to download anything that way only remove google apps

Thanks for sharing, gsvelto. I tried the process (“From the storage settings I ejected the SD card…”) that is described in your post, but it did not work in my case (FP3+, Android 10, SD Card Kingston 64 GB).

Hi @Sandro.

I’m not sure exactly what you did but to clarify.
if the SD card is formatted as internal it is encrypted and can’t be read outside the phone.

You must remove everthing from the SD card before removing it or if you remove it do not reformat it untill the phone is working and you have all your data secure else reinset and try again.

Only reformat the SD card once a) the phone is working without it and b) after you have copied all the data that was on the combined internal SSD &SD card somewhere safe ~ either off the phone or clearly on the internal SSD memory.

I just had the exact same problem. Did you manage to fix it?

Hello same thing happened to me, did you find a solution?

Hi @Fabiana_Leibl Welcome to the forum

Sadly quite a few people choose to format as internal and come up with problems. There is no single solution, it depends upon what you have done, in detail and what you can do. Generally if you have tried to resolve it by removing the SD and making any changes it will very difficult.

But you haven’t detailed your problem, is it something that doesn’t work, have you lost data etc.


Thank you! I have experienced the same problems detailed by other users. I can’t access my pictures, I can’t download or send any images on WhatsApp and my camera no longer works.
I’ve taken the sd card out but did not make any changes. I was just asked to reinsert it, which I did.
I was looking into possibilities to decrypt the micro sd card, but maybe that’s not an option?
Looking forward to any guidance on this, it’s quite a despairing situation seeing that I no longer have access to any of my pictures or videos… Thank you!

Hi. Removing the SD card, if it formatted as internal is not a brilliant ideas as when the SD card is formatted as internal, not only is it encrypted to the phone but some of the apps store their settings there too. Reinserting without making any changes to the phone would hopefully bring you back to where you before removal.
Try clearing the caches on all the apps, especially the camera and Whatsapp

Settings > Apps and notifications > See All ## apps> Camera etc.

Check the storage to see how much memory is used by each.

Even if you succeed in getting the SD decrypted there’s no guarantee your data will be there.

Once you have resigned yourself to loosing your date one option you may like to try is to use the phone to reformat the SD card as Portable. This will move all data back the phone memory if there is enough space, some of your data may become accessible.


I’m not sure it’s automatic, you have to do it yourself (as I detailed in a previous post I believe).


Thanks I haven’t tried, I’ll have to read up on it. I thought once the option was elected the OS would ask what you wanted to do and it may have just been a matter of selecting app data and media.

Edit: :frowning: I can’t find any ref to my idea that it may be a simple process of phone instructions. I haven’t found your other post, but all I’ve read implies

  • Manually move everything you can/want keep of the SD card, which is difficult I imagine and impossible for those that have incurred the wrath of failures to find media and operate the camera etc.


I have just tried an Internal formatting of the SD card and the Storage Memory readings are a bit weird.

Note the SD card is listed as 32Gg when is is only 16Gb. It appears as though it has added the used memory in the SSD to that of the SD card ???

When the SD-card is added to the internal memory, the used space is added together, as they are both part of the same logical volume.


I imagine something like that, but do not understand the reasoning. It doesn’t make any sense to me and looks all wrong :no_mouth:

Why does it look wrong?
You decided to add more memory to the internal storage. Now it is 96 (64+32)GB instead of 64GB. And 33.5(16,74+16,75)GB of it is already used, sounds completely logical to me.