English

Android 10 FP3 WiFi Hotspot: Toyota Corolla can no longer access internet

I drive a Toyota Corolla (2019) with Touch & Go software. The car connects to a WiFi hotspot on my FP3 to access Toyota’s internet services. This worked fine with Android 9 but does not work any longer after upgrading the FP3 to Android 10. The car still connects to the hotspot but is unable to access any server (car’s display shows an error message).

I tried various configurations this afternoon and found out some interesting details:

  • Car connects to FP3 Wifi hotspot, FP3 connects to the internet through LTE
    -> Car cannot access internet (as described above)

  • Laptop connects to FP3 Wifi hotspot, FP3 connects to the internet through LTE
    -> Laptop can access internet, so it seems to be an issue with the client device (however it worked with Android 9)

  • Car connects to FP3 via bluetooth tethering, FP3 connects to the internet through LTE
    -> Car cannot access internet

  • Car connects to FP3 via bluetooth tethering, FP3 connects to the internet through WiFi of my apartment
    -> Car can access internet! Too bad I cannot carry my apartment with me :wink:
    Why does it work that way? From the car’s point of view nothing should have changed.

I also tried disabling the WiFi hotspot’s security, but it didn’t help.

Any ideas?

Did you try a #dic:factorydatareset?
Is your car firmware up to date?

A factory reset is the last resort when nothing else helps. Restoring the phone to the same state before the factory reset takes a couple of hours that I don’t want to spend right now…

Anyway, I will bring the car to the garage for the annual service within the next few weeks and ask the guys to install the latest firmware. Hopefully the problem resides on Toyota’s side AND they have fixed it (fingers crossing).

However something must have changed on Fairphone’s side because it worked with Android 9.

1 Like

Unfortunately, a factory reset can prove to solve many different problems, and a certain number of people reported that it had solved some of the problems that had occured after the upgrade. It is of course up to you to decide if you feel like doing one (waiting for a possible firmware update before may be a good idea, indeed).

I have the same car (happy with it so far) and also the same Touch & Go software and I’ve noticed that message too. But didn’t give it much more thought. I’m not sure entirely what the “internet connection” in the car really is used for as none of the apps work.

I will check to see if it is as consistent in my car as it is in yours.

Did you try a full re-pairing of the phone and the car system? If not, I will try this later.
Additionally, I’ll try find some support from Toyota directly. It’s a popular car, so they might have more people reporting in with Android 10.

1 Like

I observe exactly the same phenomenon as Harald reported.
The only difference being my car is a Kia Optima with TomTom based navigation.
Summary of the main observations:

  • All worked fine with Android 9.
  • Since update to Android 10 last Friday, FP3 WiFi Hotspot still connects to car, but no internet (traffic) data via mobile network.
  • After starting the car, successful FP3 hotspot connection is indicated on both sides FP3 and car.
  • Usual indication of availability of online-traffic data on car display never shows up.
  • For other applications on FP3, mobile internet access is working fine at the same time.
  • No restart or force stop of all application or re-establish or modify WiFi connection or change to Bluetooth tethering or change of WiFi frequency etc. has any effect.

I have the strong feeling that this problem has nothing to do with car system.

Best regards
Michael

Here’s an update. It’s still not working, although I tried various things (see below). At least the car can perfectly connect to the internet through the hotspot of my wife’s Huawei P30 lite which also runs Android 10, so this is not a pure Android 10 issue. It’s exactly the combination of car, FP3 and Android 10, and only this combination, that does not work. Weird…

I tried these things that did not help:

  • use the FP3’s “reset Wifi, mobile connection and bluetooth” option
  • reset the APN settings to default
  • clear caches and data of various network related apps (e.g. carrier services)
  • pair car and phone again
  • disabled second SIM card
  • switched mobile data to second SIM card (other network provider)
  • in the APN settings, add “DUN” APN type (as suggested in other forums)

The phone was rebooted after each of these measures.

My car is back online. :grinning:

tl/dr
I had to change the APN settings. I believe there is a bug in Android 10: If the client of the WiFi hotspot only supports IPv4, but the APN for the mobile network is configured for IPv4IPv6 then the mapping of the IP addresses seem to fail. Please give this information to your develop department.

Full story:
I noticed that the APN settings of my Telekom SIM card are different from those documented on Telekom’s website, so I decided to change the settings manually. The result was a disaster. I completely lost mobile data connection. Worse, after resetting the APN settings (using the built-in reset function) and rebooting the phone, mobile data still did not work at all. Great. :frowning_face:

I removed the SIM card and put it back into my old FP2. It worked like a charm. Then I noticed that the FP2 uses entirely different APN settings that neither match the default APN settings on FP3 nor the settings documented by Telekom. So I decided to write them down on paper, put the SIM card back in the FP3, and manually edit the APN settings on FP3 to match those on FP2. Finally some cache cleaning, a reboot, and - voila - mobile data was back again. :relieved: And even better: now the car can access the internet again through the hotspot. Yipee!

One difference between the old and new APN settings is the protocol. The old (working) uses IPv4 while the new (not working) uses IPv4/IPv6. Here is my hypothesis:

  • The Toyota only supports IPv4 (?)
    UPDATE: my original guess seems to be wrong. I got me the adb-tools and checked the log files. It seems that the car uses an IPv6 address. Must do further investigations.
  • Connection to the mobile network requires IPv6 (suggested by the APN’s name internet.v6.telekom)
  • So the phone has to map IP addresses when routing the traffic from the car to the network and vice versa. And that mapping does not seem to work properly.

I’m also relieved that I didn’t need a factory reset that probably would not have fixed the problem.

5 Likes

This is a community forum, not the company.
But perhaps @rae could forward this accordingly.

1 Like

Sorry, I wasn’t aware of that.
What’s the best way to submit a bug report?

Contacting Fairphone support.
But @AnotherElk already mentioned Rae and she will forward it to fairpone.

1 Like

Interesting. Devices without IPv6 support are very rare (even Windows XP was updated to support it.) I think Toyota is partly to blame here for not supporting IPv6, or failing to connect to IPv4 if any IPv6 service is offered.

Can anyone suffering from this bug connect a computer to an FP3 hotspot to check whether the computer receives an IPv6 address (that is not starting with fe80)? On Windows you can see this by clicking the network name > properties, then scrolling down to the bottom; on Linux you can run ip a in terminal.

2 Likes

I got me the adb-tools now (should have done this earlier) and grabbed some log files. Seems that my original hypothesis was wrong as a find this line in the logs at the time the car connects to the hotspot:

09-18 16:30:18.812 869 869 I wificond: New station 74:d7:ca:c9:89:35 associated with hotspot

This is clearly an IPv6 address.
As soon as I have time I will revert the APN settings to the non-working version and repeat the test. Maybe there’s more to see in the logs.

btw: the APN on my wife’s phone (whose hotspot properly works with the Corolla) also uses IPv4 only.

That is not an IPv6 address, that is the car’s MAC address. 74:d7:ca at the start of a MAC address points to Panasonic Automotive, which is likely the manufacturer of the car’s computer.

IPv6 addresses consist of eight blocks rather than six and can have up to 4 characters in every block. If there are less than 8 blocks, there is always a double colon ("::") somewhere in the IPv6 address.

A test of the hotspot is best performed on a computer connected to the hotspot through wifi, as computers have easy tools to find all relevant addresses.

Your mobile operator may be in the progress of rolling out IPv6 and thus may have rolled out new APNs to phones who joined the network after a certain date?

3 Likes

Thank you for the - time consuming - investigation! Really appreciate it. I didn’t have the same problem. I’m using Blau (Telefonica) as mobile provider.After the upgrade the Hotspot still worked as before. I did need to enter the wifi password again.

Hello Harald,
congratulations that your problem is solved.
Still, my problem (exactly the same as yours, but different car, see my report above) persists.
I also tried different APN settings, apart from all the resetting, but no success. (I observe that my FP3 still has mobile internet access while the WiFi-hotspot problem is there.)
Before trying any severe measures like factory reset, I’d like to be sure that nothing else helped. Therefore, in case you have any additional conclusions or findings about what triggered or caused the problem and of course what exactly solved the problem, I would be grateful if you could share them.

Thanks
Michael

P.S.
Looks like nobody else is suffering from this problem?

Hi Michael, please connect a computer to your phone hotspot to check this, because there were some hints it may be IPv6-related. It would help us forum users to investigate why this problem is happening:

1 Like

When I connect FP3 hotspot to my laptop-PC, the properties of the Fairphone hotspot show the following:


SSID: Fairphone 3 AP_2689
Protokoll: Wi-Fi 4 (802.11n)
Sicherheitstyp: WPA2-Personal
Netzfrequenzbereich: 2,4 GHz
Netzwerkkanal: 6
IPv6-Adresse: 2a01:598:a973:[SNIP]
Verbindungslokale IPv6-Adresse: fe80::fd5c:80f9:f5d5:ed48%17
IPv6-DNS-Server: 2a01:598:a973:[SNIP]
IPv4-Adresse: 192.168.43.159
IPv4-DNS-Server: 192.168.43.190
Hersteller: Qualcomm Atheros Communications Inc.
Beschreibung: Qualcomm Atheros AR5BWB222-Funknetzwerkadapter
Treiberversion: 3.0.2.201
Physische Adresse (MAC): 20-68-9D-44-C5-71

1 Like

Hi AlbertJP,

when I connect FP3 hotspot and laptop-PC, the properties are:

Thanks, you have an IPv6 address of Deutsche Telekom on your hotspot. That’s nice, but now we need to know whether connecting to an IPv6 website actually works. Could you check whether IPv6 is functional over the hotspot on test-ipv6.com ?

Either the car doesn’t support IPv6 at all, or it fails to fall back to IPv4 if IPv6 is not functional. In the former case, we can only blame the car, in the latter case, we should blame the phone as well.

2 Likes