Amaze grant SAF access

I use the app Amaze file manager.
I get the following message.

I can’t find where to set the SAF access.
Where is the system’s file manager?

Just speculating: Have you tried through Settings > Storage > … and in the pre-installed Files app?

No that doesn’t help.
In Settings, Storage


and through Settings, Apps

OK, I have been able to recreate the issue now (with Amaze 3.10 from Aurora Store), my previous two posts didn’t contribute anything to a solution, so I deleted them. No solution found by me either, sorry! :thinking: I vaguely seem to remember “Storage Access Framework” is something not available on a standard installation of the operating system.

ADDITION (30 June): While I was able to reproduce the problem both on Amaze 3.10 (from Aurora) as well as Amaze 3.8.4 (F-Droid/ e App Lounge), I noticed that 3.8.4 allowed me to enter the Android folder at least one level “deeper” (i.e. I was able to view a folder’s contents which 3.10 did not enable) before getting the same SAF prompt.