Alarm not starting if FP2 is off

##Original Post:

I really loved the feature of the FP1 where the alarm clock was working when the phone was switched off. Somehow this feature is not working for me on the FP2.

I did different tests, but it won’t work.

Anyone with the same issue or a solution?

Thanks for your help.


:warning: While this works for some people, others will get stuck on an endless boot loop when enabling quickboot mode.


I haven’t received my FP2 yet, but this would/will be an annoying problem for me as well as I will want to use the alarm clock 5 days a week, and leaving the phone on all night is not an option for various reasons.


You could put your phone on airplane mode, which is turning all connections off to avoid being disturbed, waves and considerably diminish battery consumption. That’s what I do every night with my current phone.


This is standard behaviour for an Android phone. I’m not sure how they got round it with the FP1. I just put it on silent and aeroplane mode.

Actually I think that the FP1 is an exceptional phone in that way, as most smartphone don’t support turning on for the alarm clock. I also felt it was a great feature, and I don’t understand why this is not a standard for phones.

That said, I always encrypt my phone drives. With an encrypted drive also with the FP1 this feature didn’t work: the phone would turn on, but then asking for your password before booting, so basically you don’t get to the alarm clock while asleep.

Thus at home I have an extra alarm clock (some thing that I needed to get after changing from regular phones to smartphones, which also made me wonder which phones are actually smarter) or I also use the flightmode.

I think for enabling the phone while shutdown, additional hardware like a real-time clock (RTC) is needed. I don’t think this is available on FP2 (maybe there is a RTC, but I haven’t read about yet).

What you can do is enable QuickBoot mode: first enable Developer options by tapping the Build number ten times in Settings -> About phone. Then go to Settings -> Developer options and enable QuickBoot mode. Now turning your phone off won’t actually fully power it down, and the device is able to wake up for an alarm.


Thanks. Just tested and this works. Now I’m wondering if I also did this trick on the FP1…

which impact to this “QuickBoot” in general? More power consumption during “switched off”, faster boot time?
Who knows more details?

I advice extreme caution with the “QuickBoot” mode! It made my FP2 unusable for now. Any help would be appreciated in this thread.

EDIT: My FP1 made it out of its “QuickBoot”-induced boot loop itself when I left it on looping over night. But after that shock I’d rather go into flight mode when I want to use the alarm clock from now on.

I just tested and QuickBoot Mode works perfectly for me.
It takes only a second to boot the device! :open_mouth:

I did this last night and it worked when after I turned it out. It went on again afterwards. But this morning it didn’t go off, and when I turned the phone on, it kept saying ‘loading…’. And very short it said ‘starting app 1 of 94’ or the same massage with other digits. Then I saw the blue page with Fairphone and it started reloading again. Just over and over. I can’t get it started anymore. I took out the battery.

That happens a lot unfortunately, I’ll edit the first post warning about quickboot mode.


It happened to me as well after the software update. It worked in the beginning and after a night it started rebooting when I switched it on. More over the alarm didn’t ring even thogh yesterday I tried it and it worked afte putting the quick reboot settings.

[Edit: Found in another thread that the option disappeared with an update because till now fairphone could not solve the boot loop issue.]

Hey guys,
I got my fairphone 2 recently and I’m struggling with the alarm as well. Maybe it’s a stupid question but where exactly can I find the quick boot option. I think I read the tenth time all available settings in the developer settings section and couldn’t find it.
Maybe the option is gone with an update?
[Fairphone 2 open OS 16.08.0]