English

Alarm can't be turned off

I have had the same problem this morning!

I was trying to stop the alarm or turn the telephone on but only black screen and the music from the alarm.
I thought “ohh, my Fairphone is dead”.

Finally the phone turn on, I don’t know why.

Hm. Usually, the screen backlight switches on, the phone stays like this for a while (I guess it boots, silently, without showing the Fairphone logo), and then displays the app and starts playing the sound.

@Ana_Linux_Spain, did you install/deinstall/update any apps before this happened?

Seem like in both your cases, the app is misbehaving. Besides de-installing recently installed apps, which you probably already tried, I would suggest to turn the phone off, reboot, go to apps management and delete cache and data from the clock app, turn the phone off again, reboot and set a new alarm for a test.

If it still does not work, I would again do the same steps, but additionaly wipe the dalvik cache before you reboot. You can do that, e.g., by booting to recovery mode and selecting cache wipe, or using an app which provides that option, like TitaniumBackup.

If this still does not fix your problem, I’d probably do it again. Just in case. And then I’d consider a factory reset. :wink:

1 Like

Interesting. Thanks Ana. Sadly mine just doesn’t turn back on again – I have to take the battery out. Alexis

Nothing is displayed. Nobody comes. Nobody goes. It’s like a Samuel Beckett play. Except for the sound of the alarm!

Thanks humorkitik !!! The last two times I had exactly the same problem as AlexisRowell, then I made only the first steps that you suggested :smile:

I would suggest to turn the phone off, reboot, go to apps management and
delete cache and data from the clock app, turn the phone off again

and now it works again correctly :blush:

Hope it did also for AlexisRowell too !

Regards

1 Like

Seems to have worked for me too. Thanks all, Alexis

2 Likes

Continuing the discussion from Alarm can’t be turned off:

Why are you closing so quickly this topic ?!!

…It worked for sure but the day after it was exactly the same again. Even worth then now when the alarm rings nothing is to see on the display.

So, to delete the cache of the clock app isn’t enough at all !

There was no reply for some days and you had said that “it works again correctly”.

BTW you could have sent me a pm and I would have opened the topic again.

1 Like

Sorry Stefan, I am sick and either did I think to post something here at the right moment nor I was able to write you a PM, sorry :confused:

1 Like

Yes, I spoke too soon as well. It worked a couple of times then this morning it went back to not working. :frowning:

I have this sometimes when I have the alarm on for longer, the screen blacks out again but the option to slide to turn of the alarm or snooze was there.

Then if I turn on the screen again the phone is locked, I have to unlock it all while the alarm is sounding. Then I can turn off the alarm, but I have to go to the clock app, then alarms, then turn it off.
Sometimes the alarm is in the notification bar, and I can turn it off that way, but sometimes it isn’t and I have to open the clock.

It’s a small nuisance but not worth troubleshooting for me. Mostly I am awake before my screen times out again. You could also try having a longer screen time out setting, and see if that allows you to turn off your alarm?

Since the big software update I have the same problem. My alarm goes off, I swipe to stop the alarm and turn on the phone and sometimes the alarm keeps going off. I have to restart my phone to stop the sound of my alarm.
It never did that before the software update. It is not all the time, he did it now three times since the update.
Anyone an idea to resolve this problem?

I have the same problem.

Sometimes it is not possible to stop the alarm.
The phone starts, but the music doesn’t stop.

Any news on how to solve this problem?

I’ve now learnt to live with it, James. But thanks, Alexis

Yes, I’ve had this problem for nearly a year now. It’s a pain. But it sounds like my problem is a slight variation on yours – 50% of the time when the alarm goes off the screen is blank and the only way I can turn the alarm off is by taking out the battery. I’m afraid I’ve just learnt to live with it.

Alexis

For the first time this morning I have had a similar problem.

I don’t set any alarms but on my way into work I could hear an alarm going off. Didn’t think it was mine so walked on until I realised it was following me! The phone screen was just displaying my usual wallpaper so there was no option to turn the alarm off so I had to shut the phone down to get it to stop.

Usually my alarm works ok, but every so often I have a similar problem. When the alarm sounds I turn it off and everything looks normal. Only a little while later does it decide to start going off again (and I promise I’m not hitting snooze by mistake!). When this happens it can’t be silenced except by turning the whole thing off. It’s probably more of a problem for my neighbours whom I share a wall with, because I’m usually in the shower and out of earshot by the time it decides to go off again…

Since you are experiencing crashes also, it seems that your system got messed up quite a bit. Maybe it is indeed time for (a proper backup and) a hard reset.

A post was split to a new topic: Alarm can’t be turned off (Fairphone 2)