Alarm can't be turned off

If I set the alarm on my Fairphone, and then turn off the phone, the alarm goes off the next morning as scheduled, but there’s no way to turn it off. You have to remove the battery, and therefore reboot it, in order to stop the alarm. Anyone else seen this problem?


No haven’t experienced this. This always has been working for me. Please change the category to “Help” as it doesn’t seem to be a bug of the Fairphone software to me yet.

Maybe an app you installed is causing your issue.

Thanks Stefan. Any idea what sort of app might have caused that? Something that uses clock features perhaps?

Very probably. Do you have such an app installed?

Nope. The only apps I’ve installed since the last big Fairphone software update (which is when my alarm stopped working) are:

Bubble (spirit level)

Compass 360 pro (compass)

PassWallet (tickets)

Nationwide (banking)

Rgds, Alexis

Maybe something went wrong during the update. Could you try updating again?

Just to clarify, the alarm is set by the standard clock app, and entirely as expected in every other way? (i.e.: playing the correct sound file, showing the usual display message with the swiping options right to turn off and left to snooze, etc.)

1 Like

That’s right, Hans. Everything else seems to be working on the clock app – I just can’t turn the phone on to turn off the alarm when it starts ringing.

Well turning it on through the power button won’t work, because it already is powered on, when the alarm goes off.
So you cannot turn off the alarm by moving the circle in the middle to one of the three options?

Since you said, this started with the last big update (I assume to 1.8?), something might have gone wrong during the process. I suggest you rerun the update.

This is really odd. You are sure that the round thing in the middle is not movable to a side if you touch and hold it? Weird.

Buttons, including power, are not working when the alarm rings after waking up the phone. I tested that. Seems ok, as long as you can use the touch screen. But this? Weird.

When the alarm works properly (besides the ability to turn it off) this means your phone has already booted, and the app is working. I can’t spot any app in your list which should interfere with that, but I guess that both the banking app and the ticket app have some sort of password protection, which might (but this is a very wild guess!) interfere with system apps, including .

I guess you de-installed all the apps you mentioned already? That might be worth a try before going through the update again.

But it doesn’t restart/wake up Hans – it simply rings but stays resolutely off/dead. Cheers, Alexis

So to clarify: The screen does not go on? Nothing is displayed?

I have had the same problem this morning!

I was trying to stop the alarm or turn the telephone on but only black screen and the music from the alarm.
I thought “ohh, my Fairphone is dead”.

Finally the phone turn on, I don’t know why.

Hm. Usually, the screen backlight switches on, the phone stays like this for a while (I guess it boots, silently, without showing the Fairphone logo), and then displays the app and starts playing the sound.

@Ana_Linux_Spain, did you install/deinstall/update any apps before this happened?

Seem like in both your cases, the app is misbehaving. Besides de-installing recently installed apps, which you probably already tried, I would suggest to turn the phone off, reboot, go to apps management and delete cache and data from the clock app, turn the phone off again, reboot and set a new alarm for a test.

If it still does not work, I would again do the same steps, but additionaly wipe the dalvik cache before you reboot. You can do that, e.g., by booting to recovery mode and selecting cache wipe, or using an app which provides that option, like TitaniumBackup.

If this still does not fix your problem, I’d probably do it again. Just in case. And then I’d consider a factory reset. :wink:

1 Like

Interesting. Thanks Ana. Sadly mine just doesn’t turn back on again – I have to take the battery out. Alexis

Nothing is displayed. Nobody comes. Nobody goes. It’s like a Samuel Beckett play. Except for the sound of the alarm!

Thanks humorkitik !!! The last two times I had exactly the same problem as AlexisRowell, then I made only the first steps that you suggested :smile:

I would suggest to turn the phone off, reboot, go to apps management and
delete cache and data from the clock app, turn the phone off again

and now it works again correctly :blush:

Hope it did also for AlexisRowell too !


1 Like

Seems to have worked for me too. Thanks all, Alexis


Continuing the discussion from Alarm can’t be turned off:

Why are you closing so quickly this topic ?!!

…It worked for sure but the day after it was exactly the same again. Even worth then now when the alarm rings nothing is to see on the display.

So, to delete the cache of the clock app isn’t enough at all !

There was no reply for some days and you had said that “it works again correctly”.

BTW you could have sent me a pm and I would have opened the topic again.

1 Like