English

After OpenOS-Update Playstore and Youtube are broke; battery life is now extremely poor

I have updated to the newest version of fairphone openOS yesterday. Before that youtube and playstore were fine. Now the homescreen of the youtube app doesnt have any videos and is constantly shwoing the loading sign. When I let my browser open a video with the youtube app, however, it plays the video and I can switch to videos in the recommended bar. If I swipe the video in the corner, there is the homescreen again, devoid of videos and showing the loading sign over a see of white.

Playstore is just white window now.

My battery used to be meh, but now it’s atleast as bad as that of my ancient galaxy s1. Today I woke up at 8:30. I played asterix and friends for ca 15 minutes and surfed in a forum for another 5 minutes and my phone actually dropped to 30 %. My phone, having charged over the night, was full. Before the update, 15 minutes of A&F would bring it down to around 80 or 70 %. But it gets even more ridiculous. I went for a 30 min walk and by the time I had break fast my phone was at 19 % and still oosing power. During the walk I had the phone on stand-by, only using it for an alarm in the background, which would usually consume no significant amount of power.

It charges incredibly slowly. In stand-by it charged from ca. 15 % to 64 % in over three hours. It doesnt charge at all when I do even light tasks as forum browsing. It will drop to zero quickly if I watch youtube videos or play Asterix & Friends during charging.

I always have the lowest possible brightness and I have turned GPS and bluetooth turned off. I never had this extreme issue before the update.

For context, besides the pico package of the google play apk I also have xframework.

I really need my smartphone for learning, so I appreciate if someone knows how to solve this quickly, in the best case without having to wipe my data.

Hi,

If you have update an OpenOS you may have to install gapps again, I think you may find solutions see here.

For youtube I use newpipe which works great for me :wink:

3 Likes

See the #batteryguide for hints.
Also keep in mind that batteries don’t last forever, their mileage will get worse once they get older.

2 Likes

I have replaced the battery with a spare one I have bought four months ago. It has the same problems, so it’s clearly a software issue, coming from the update.

There is more hardware than just the battery in the phone.
E.g. a faulty bottom module, main module or an old SIM card could also cause the battery to drain fast.

Thanks, Gapps are working after I have reinstalled them. My battery is still shit though, even after I have changed it for a spare one.

But I have told you that it is since the software update. What are the chances that the hardware fails just after getting a new update which has already proven to be disruptive in another way?!

You’re right a software issue is more likely.
I’d try reinstalling the OS or openGAPPS.
If neither does the trick than a #dic:hardreset probably will.

1 Like

Thanks in the end I had no choice but to reinstall OpenOS and atleast it worked then.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.