After android 13 upgrade FP4 freezes

When the issue happens, a reboot is required.
You can prevent that by turning off auto-rotate.
But that is not a solution, it’s a workaround.

1 Like

Yes indeed. It seems to solve the problem for the moment. At least the problem never occur since then…

1 Like

Same here - turning off auto-rotate is the only solution - support is not helpful, so THANKS for the forum help :heart:

With auto-rotate disabled, as well as with animations turned off, cell connectivity limited to 2-4G (no 5G), and no SD card in the device, I still get occasional freezes. If it shows the last image, I can usually get out of full screen mode somehow, but yesterday I got a black screen again with no option other than to force a reboot. So turning off auto-rotate is not a workaround. It may or may not affect how often the problem occurs.

For me the last update didn’t change anything concerning this issue. Still screen freezes, if auto-rotate is on. When I turn it off, no screen freezes.

Same here… i can repeat the problem on demand by playing a youtube video in horizontal position, switching screen off, rotating to vertical and switching on… phone goes black and unresponsive while audio still going. Worked around it by switching auto rotate as stated above in the thread for now.

Yes, the latest upgrade doesn’t address this problem. In case people aren’t aware, with auto rotate turned off, you can still rotate the screen by turning it to landscape, then clicking the screen icon that appears in the top right corner.


I cannot replicate according to your description.

Maybe I didn’t explain it well, or maybe your phone is different, but here’s the icon that appears on my phone when I turn it sideways.


Thanks, but I was replying to @Tomas_Vrabec regarding the attempt to replicate the issue.

1 Like

Today I had a screen freeze (black screen – had to restart the phone) even with auto-rotate off. I was using an app that seems to ignore the setting and does auto-rotate on its own.

1 Like

After explaining the issue one more time to the support, they answered on November 6th:

Thank you for your message and for providing the link to the forum post.

To help you further with your request, I will need to ask for advice from the relevant department. As soon as we have an update, we will get back to you.

If you have any other questions or concerns in the meantime, please let us know.

But no more news since then.

1 Like

I have the same issue. It also started after the android 13 upgrade. My FP4 freezes multiple times a day. Sometimes waiting a couple of hours fixes it. But usually I take the battery out to restart. Once this happened multiple times in a row while i was commuting. This was very annoying since I could see that I received an important message, but was not able to use my phone for over 30 minutes.

Have you tried turning off auto-rotate?


You can long press power (>15s) or power + vol-down (>15s) to do a force restart. No need to take out the battery.

This sounds a little bit like the 5G bug. So did you try to disable 5G?

1 Like

In hindsight of all the new revelations, I think the title of this topic represents the real problem less and less. There now are even other threads probably concerning the same issue:
FP4 black screen in YouTube after Android 13 upgrade
Phone freezes after latest update

Something like…

Occasional screen freezing on FP4 with Android 13 (mostly black screens) – hardware buttons still responding

would fit much better.

1 Like

Have anyone heard, if the developers are trying to fix this very annoying issue, or if they have set a date for, when they expect to have a fix ready for installation?

There has been ongoing work on 5G related reboots, and the fix is to be expected around seasonal festivities:) not sure if and how much it is connected.

1 Like

I got a message from support today concerning this issue:

Thank you for your patience.
We apologize for the inconvenience caused by the display issues you experience.
Rest assured, we are currently thoroughly investigating the root cause of this issue and are working on a permanent solution.
In the meantime, please keep Auto-rotate disabled.
We are grateful for your patience and understanding as we work to resolve this issue.
We will keep you updated on the progress of our investigation.