ADB detects fairphone, but fastboot mode not


I have a few questions about how to install sailfish os 2.

I have Fairphone OS 1.7.1 currently installed on my Phone. Can i actually install sailfish os 2 with fastboot on this version, or do i have to downgrade? Or do I have to install Open OS anyway?

When I install Open OS 16.10.0, which verison of sailfish os 2 should i donwload? Do I have to take a lower version of Open OS?

I tried to access my Phone (in fastboot mode) on my computer with the command “fastboot devices”, but I didn’t get any results. Is this due to the fact, that I have Fairphone OS 1.7.1 and I need Open OS?

I hope it isn’t too confusing.

Maybe anyone could help me.


did you enable developer mode and in dev-mode the usb-debuging?

Yeah, I already did that. Are there maybe any other settings to change?

Yes, in deed. Swipe top to botom and have a look if you see the usb - connection options.
The thing is, you have to UN-check all options. :joy:

if that also doesn’t work try this on your ubuntu terminal:
$ wget -S -O - | sed “s//$USER/” | sudo tee >/dev/null /etc/udev/rules.d/51-android.rules; sudo udevadm control --reload-rules
and replace with your computers user you can find in the right uper corner…


Hmm, I think i don’t get it at some point:

When I connect my phone via USB, and type the command “adb devices” i can see my device.

When my phone is in fastboot mode and connected via USB, i don’t see my device when i type “fastboot devices”.

Do you know what i might understand wrong?

Thanks for your help, I really appreciate that.

1 Like

im sorry. i was mixing the two states of the phone fastboot and adb…
in the meantime i was editing my post:

or try to add these two lines to the udev rules under /etc/udev/rules.d/51-android.rules
# Fairphone 1
SUBSYSTEMS==“usb”, ATTRS{idVendor}==“0bb4”, ATTRS{idProduct}==“0c03”, GROUP=“users”, MODE=“0666”
# Fairphone 2
SUBSYSTEMS==“usb”, ATTRS{idVendor}==“2ae5”, ATTRS{idProduct}==“9015”, GROUP=“users”, MODE=“0666”

I have win 10 so i won’t be able to perform this statements. Or is there a way?

I also checked the drivers, which should be okay. SDK is also installed properly, so the mistake has to be somewhere else.

This is the guide which i have been trying to do:

You can always use a GNU/Linux Live CD or something like that if you want.
If you need help with that, just let us know :wink:

So i can take Knoppix and try to do the statements from novski.

If i do so, i have to do everything via Knoppix. That means that i will have to write the “fastboot commands” in the Knoppix terminal too. Am i right, or did i understand something wrong?

I don’t see a reason why fastboot should not work if adb does…
Are you certain your phone is in bootloader mode ? ie, try to run “adb reboot bootloader” to be sure, instead of using the shortcuts.

Also, yes a live USB (or CD) linux can help you. You can jump as well on the occasion and install it aside your windows, this can’t hurt :slight_smile:

With “adb devices” I can find my Fairphone.

Then i write “adb reboot bootloader” and afterwards “fastboot devices” should find my phone, but it doesn’t.

When i write “fastboot device”, it says: “< waiting for device >”. When i google this problem, i can often read, that if that occurs there might be wrong drivers installed.

Some people say the problem is because when the phone is “normally” connected, it needs other drivers then when it is connected with fastboot mode.

But I think, me driver ins fastboot mode should be okay. (on screen)

What is Kedacom ? Does it mean something in german ?

Or is it the brand of another android device ? If so, you should uninstall this driver and install a generic android driver instead.

1 Like

I found the problem. Its really the Kedacom driver. I uninstalled it. Afterwards, i could set another driver for my device. and then it worked for a short time. Because while i was doing that, the device automatically installed the kedacom driver again, and i then it didn’t work anymore.

I don’t know where this driver comes from. Does anyone know how to avoid that this driver installs itself automatically?

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.